|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- NCA logging configuration file
The ncalogd.conf is used to configure Solaris Network Cache and Accelerator (“NCA”) logging. The file contains two fields, key and value.
The status key is used to indicate if the user wants to have NCA logging turned on. If the value of status key is enabled, then NCA logging will be turned on. If the value of the status key is disabled, then NCA logging will not be invoked. The default value is disabled.
The logd_path_name key specifies the absolute pathname of the log file. The log file must be a raw device without a filesystem or a file on a local file system. The default value is /var/nca/log. logd_path_name can also contain a whitespace-delimited list of values for multiple log files to a maximum of 16. If you specify multiple log files, you must enclose the list in quotation marks (“). With multiple files, NCA logging moves to the next file on the list once the file size specified by logd_file_size has been reached. When the last file is full, NCA logging rotates back to the first file in the list. A pointer to the current log file is stored in /var/nca/current.
The logd_file_size key specifies the value of the file size, in bytes, allowed for each log file specified in by the logd_path_name key. The default value is 1000000 bytes.
In order to implement changes to the ncalogd.conf file, you will need to stop and start NCA logging or reboot.
NCA stores logs in a binary format. Use the ncab2clf(1) utility to convert the log from a binary format to the Common Log File format.
Example 1 A Sample ncalogd.conf File
The following is a sample ncalogd.conf file that specifies three log files:
# # NCA Log Daemon Configuration File # status=enabled logd_path_name="/var/nca/log1 /var/nca/log2 /var/nca/log3" logd_file_size=1000000
Note that there is no NCA logging daemon. Logging is performed as one of the functions of the NCA software.
Lists configuration parameters for NCAlogging.
See attributes(5) for descriptions of the following attributes: