|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- configuration file for default router(s)
The /etc/defaultrouter file specifies a IPv4 host's default router(s).
The format of the file is as follows:
The /etc/defaultrouter file can contain the IP addresses or hostnames of one or more default routers, with each entry on its own line. If you use hostnames, each hostname must also be listed in the local /etc/hosts file, because no name services are running at the time that defaultrouter is read.
Lines beginning with the ``#'' character are treated as comments.
Use of a default route, whether received from a DHCP server or from /etc/defaultrouter, prevents a machine from acting as an IPv4 router. You can use routeadm(1M) to override this behavior.
Any default routes specified in /etc/defaultrouter will be applied during boot, and will not be preserved across changes to the active Network Configuration Profile. The route(1M) command, with its -p option, provides a means to set per-NCP static routes. In addition, a default router may be identified for a specific interface within a given NCP; see the descriptions of the ipv4-default-route and ipv6-default-route NCU properties in the netcfg(1M) manual page.
Configuration file containing the hostnames or IP addresses of one or more default routers.