|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- specify legal annotations
Each file in this directory contains the NOTE (also _NOTE) annotations legal for a single tool. The name of the file, by convention, should be the tool vendor's stock name, followed by a hyphen, followed by the tool name. For example, for Sun's lock_lint tool the filename should be SUNW-lock_lint.
The file should contain the names of the annotations understood by the tool, one per line. For example, if a tool understands the following annotations:
NOTE(NOT_REACHED) NOTE(MUTEX_PROTECTS_DATA(list_lock, list_head))
then its file in /usr/lib/note should contain the entries:
Blank lines, and lines beginning with a pound (#), are ignored.
While /usr/lib/note is the default directory tools search for such files, they can be made to search other directories instead simply by setting environment variable NOTEPATH to contain the paths, separated by colons, of directories to be searched, e.g., /usr/mytool/note:/usr/lib/note.
These files are used by such tools whenever they encounter NOTEs they do not understand. If a file in /usr/lib/note contains the annotation, then it is valid. If no such file contains the annotation, then the tool should issue a warning complaining that it might be invalid.
specify paths to be searched for annotation files. Paths are separated by colons (“:”).