|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- name of the Solaris Network Cache and Accelerator (NCA) socket utility library
ncad_addr.so is the Solaris Network Cache and Accelerator (NCA) socket utility library. Use this library with a web server to avoid support for the PF_NCA family type socket. The web server can take advantage of NCA functionality.
Interpose the ncad_addr interfaces before the interfaces in libsocket by setting the environment variable LD_PRELOAD to ncad_addr.so so that it is preloaded before libsocket.so.1. The ncad_addr.so interfaces will be interposed only if NCA is enabled. See ncakmod(1).
Example 1 Interposing ncad_addr
Using Bourne shell syntax as an example, set LD_PRELOAD as shown below to interpose the ncad_addr socket utility libary:
ncad_addr socket utility library shared object
See attributes(5) for descriptions of the following attributes:
Only applications that use the NCA feature, for example, web servers, should interpose this library.