|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- specify the default file system type for local or remote file systems
When file system administration commands have both specific and generic components (for example, fsck(1M)), the file system type must be specified. If it is not explicitly specified using the -F FSType command line option, the generic command looks in /etc/vfstab in order to determine the file system type, using the supplied raw or block device or mount point. If the file system type can not be determined by searching /etc/vfstab, the command will use the default file system type specified in either /etc/default/fs or /etc/dfs/dfstypes, depending on whether the file system is local or remote.
The default local file system type is specified in /etc/default/fs by a line of the form LOCAL=fstype (for example, LOCAL=ufs). The default remote file system type is determined by the first entry in the /etc/dfs/fstypes file.
File system administration commands will determine whether the file system is local or remote by examining the specified device name. If the device name starts with ``/'' (slash), it is considered to be local; otherwise it is remote.
The default file system types can be changed by editing the default files with a text editor.
list of default parameters for each file system
the default local file system type
the default remote file system type