|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- information repository for DHCP options
The /etc/dhcp/inittab and the /etc/dhcp/inittab6 files contain information about the Dynamic Host Configuration Protocol (DHCP) options, which are network configuration parameters passed from DHCP servers to DHCP clients when a client machine uses DHCP. Since many DHCP-related commands must parse and understand these DHCP options, this file serves as a central location where information about these options may be obtained.
The DHCP inittab and inittab6 files provide three general pieces of information:
A mnemonic alias, or symbol name, for each option number. For instance, option 12 is aliased to the name Hostname. This is useful for DHCP-related programs that require human interaction, such as dhcpinfo(1).
Information about the syntax for each option. This includes information such as the type of the value, for example, whether it is a 16-bit integer or an IP address.
The policy for what options are visible to which DHCP-related programs.
If you make any changes to the /etc/dhcp/inittab file, note that only additions of or changes to SITE options are preserved during upgrade. For /etc/dhcp/inittab6, no options are preserved during upgrade.
The VENDOR options defined here are intended for use by the Solaris DHCP client and DHCP management tools. The SUNW vendor space is owned by Sun, and changes are likely during upgrade. If you need to configure the Solaris DHCP server to support the vendor options of a different client, see dhcptab(4) for details.
Each DHCP option belongs to a certain category, which roughly defines the scope of the option; for instance, an option may only be understood by certain hosts within a given site, or it may be globally understood by all DHCP clients and servers. The following categories are defined; the category names are not case-sensitive:
All client and server DHCP implementations agree on the semantics. These are administered by the Internet Assigned Numbers Authority (IANA). These options are numbered from 1 to 127 for IPv4 DHCP, and 1 to 65535 for DHCPv6.
Within a specific site, all client and server implementations agree on the semantics. However, at another site the type and meaning of the option may be quite different. These options are numbered from 128 to 254 for IPv4 DHCP. DHCPv6 does not support site options.
Each vendor may define 254 options (65536 for DHCPv6) unique to that vendor. The vendor is identified within a DHCP packet by the “Vendor Class” option, number 60 (number 17 for DHCPv6). An option with a specific numeric identifier belonging to one vendor will, in general, have a type and semantics different from that of a different vendor. Vendor options are “super-encapsulated” into the vendor field number 43, as defined in RFC 2132 for IPv4 DHCP, and number 17 as defined in RFC 3315 for DHCPv6. The /etc/dhcp/inittab file contains only Sun vendor options. Define non-Sun vendor options in the dhcptab file.
This category allows the fixed fields within a DHCP packet to be aliased to a mnemonic name for use with dhcpinfo(1).
This category is internal to the Solaris DHCP implementation and will not be further defined.
Data entries are written one per line and have seven fields; each entry provides information for one option. Each field is separated by a comma, except for the first and second, which are separated by whitespace (as defined in isspace(3C)). An entry cannot be continued onto another line. Blank lines and those whose first non-whitespace character is '#' are ignored.
The fields, in order, are:
The Mnemonic Identifier is a user-friendly alias for the option number; it is not case sensitive. This field must be per-category unique and should be unique across all categories. The option names in the STANDARD, SITE, and VENDOR spaces should not overlap, or the behavior will be undefined. See Mnemonic Identifiers for Options section of this man page for descriptions of the option names.
The Category field is one of STANDARD, SITE, VENDOR, FIELD, or INTERNAL and identifies the scope in which the option falls. SITE is not used in inittab6.
The Option Number is the number of this option when it is in a DHCP packet. This field should be per-category unique and the STANDARD and SITE fields should not have overlapping code fields or the behavior is undefined.
Data Type is one of the following values, which are not case sensitive:
A printable character string
Has no value. Scope limited to category limited to INTERNAL. Presence of an option of this type within a Solaris configuration file represents TRUE, absence represents FALSE.
An array of bytes
An 8-bit unsigned integer
An 8-bit signed integer
A 16-bit unsigned integer
A 16-bit signed integer
A 24-bit unsigned integer
A 32-bit unsigned integer
A 32-bit signed integer
A 64-bit unsigned integer
A 64-bit signed integer
An IPv4 address
An IPv6 address
An RFC 3315 Unique Identifier
An RFC 1035-encoded domain name
The data type field describes an indivisible unit of the option payload, using one of the values listed above.
The Granularity field describes how many indivisible units in the option payload make up a whole value or item for this option. The value must be greater than zero (0) for any data type other than Bool, in which case it must be zero (0).
Maximum Number Of Items
This value specifies the maximum items of Granularity which are permissible in a definition using this symbol. For example, there can only be one IP address specified for a subnet mask, so the Maximum number of items in this case is one (1). A Maximum value of zero (0) means that a variable number of items is permitted.
The Visibility field specifies which DHCP-related programs make use of this information, and should always be defined as sdmi for newly added options.
The following table maps the mnemonic identifiers used in Solaris DHCP to RFC 2132 options:
The following table maps the mnemonic identifiers used in Solaris DHCP to RFC 3315, 3319, 3646, 3898, 4075, and 4280 options:
Example 1 Altering the DHCP inittab File
In general, the DHCP inittab file should only be altered to add SITE options. If other options are added, they will not be automatically carried forward when the system is upgraded. For instance:
ipPairs SITE, 132, IP, 2, 0, sdmi
describes an option named ipPairs, that is in the SITE category. That is, it is defined by each individual site, and is option code 132, which is of type IP Address, consisting of a potentially infinite number of pairs of IP addresses.
See attributes(5) for descriptions of the following attributes:
Alexander, S., and R. Droms. RFC 2132, DHCP Options and BOOTP Vendor Extensions. Network Working Group. March 1997.
Droms, R. RFC 2131, Dynamic Host Configuration Protocol. Network Working Group. March 1997.
Droms, R. RFC 3315, Dynamic Host Configuration Protocol for IPv6 (DHCPv6). Cisco Systems. July 2003.
Schulzrinne, H., and B. Volz. RFC 3319, Dynamic Host Configuration Protocol (DHCPv6) Options for Session Initiation Protocol (SIP) Servers. Columbia University and Ericsson. July 2003.
Droms, R. RFC 3646, DNS Configuration options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6). Cisco Systems. December 2003.
Kalusivalingam, V. RFC 3898, Network Information Service (NIS) Configuration Options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6). Cisco Systems. October 2004.
Chowdhury, K., P. Yegani, and L. Madour. RFC 4280, Dynamic Host Configuration Protocol (DHCP) Options for Broadcast and Multicast Control Servers. Starent Networks, Cisco Systems, and Ericsson. November 2005.
Mockapetris, P.V. RFC 1035, Domain names - implementation and specification. ISI. November 1987.