|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- file for ftp remote login data
The .netrc file contains data for logging in to a remote host over the network for file transfers by ftp(1). This file resides in the user's home directory on the machine initiating the file transfer. Its permissions should be set to disallow read access by group and others. See chmod(1).
Tokens can be separated by SPACE, TAB, or NEWLINE characters. The following tokens are supported:
Supply an additional account password. If this token is present, the auto-login process supplies the specified string if the remote server requires an additional account password. If the remote server does not require an additional account password, the auto-login process initiates an ACCT command.
Same as machine name, except that default matches any name. There can be only one default token, and it must be after all machine tokens. The default token is normally used as follows:
default login anonymous password user@site
Such an entry gives the user automatic anonymous ftp login to machines not specified in .netrc.
Identify a user on the remote machine. If this token is present, the auto-login process initiates a login using the specified name.
Identify a remote machine name. The auto-login process searches the .netrc file for a machine token that matches the remote machine specified on the ftp command line or as an open command argument. Once a match is made, the subsequent .netrc tokens are processed, stopping when the EOF is reached or another machine token is encountered.
Define a macro. This token functions the same as ftp macdef. A macro is defined with the specified name; its contents begin with the next .netrc line and continue until a null line (consecutive NEWLINE characters) is encountered. If a macro named init is defined, it is automatically executed as the last step in the auto-login process.
Supply a password. If this token is present, the auto-login process supplies the specified string if the remote server requires a password as part of the login process. If this token is present in the .netrc file, ftp aborts the auto-login process if the .netrc is readable by anyone besides the user.
Skip the SYST command that is sent by default to all remote servers upon connection. The system command is what enables the automatic use of binary mode rather than the protocol default ascii mode.
As some older servers cannot handle the ftp command, this directive is provided to allow inter-operability with these servers.
Example 1 A Sample .netrc File
A .netrc file containing the following line:
machine ray login demo password mypassword
allows an autologin to the machine ray using the login name demo with password mypassword.
Contains data for logging into a remote host.