|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- netname database
The netid file is a local source of information on mappings between netnames (see secure_rpc(3NSL)) and user ids or hostnames in the local domain. The netid file can be used in conjunction with, or instead of, the network source, NIS. The publickey entry in the nsswitch.conf (see nsswitch.conf(4)) file determines which of these sources will be queried by the system to translate netnames to local user ids or hostnames.
Each entry in the netid file is a single line of the form:
netname uid:gid, gid, gid . . .
The first entry associates a local user id with a netname. The second entry associates a hostname with a netname.
The netid file field descriptions are as follows:
The operating system independent network name for the user or host. netname has one of two formats. The format used to specify a host is of the form:
where hostname is the name of the host and domain is the network domain name.
The format used to specify a user id is of the form:
where uid is the numerical id of the user and domain is the network domain name.
The numerical id of the user (see passwd(4)). When specifying a host name, uid is always zero.
The numerical id of the group the user belongs to (see group(4)). Several groups, separated by commas, may be listed for a single uid.
The local hostname (see hosts(4)).
Blank lines are ignored. Any part of a line to the right of a `#' symbol is treated as a comment.
Example 1 A sample netid file.
Here is a sample netid file:
unix.789@West.Sun.COM 789:30,65 unix.123@Bldg_xy.Sun.COM 123:20,1521 firstname.lastname@example.org.EDU 0:candlestick
public key database