|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- file containing parameter values for automountd daemon and automount command
The autofs file format is ASCII; comment lines begin with the crosshatch (#) character. Parameters consist of a keyword followed by an equal sign followed by the parameter value, of the form:
As shipped, the parameters in the autofs file are commented out. As root, you must uncomment a keyword-value line to make the value for that parameter take effect.
Administrators can make changes to the startup parameters for automountd by logging in as root and editing the autofs file. Changes made to autofs values on an automount or automountd command line override values in /etc/default/autofs. The /etc/default/autofs file is preserved across operating system upgrades.
The following parameters are currently supported in the autofs file:
Specifies a duration, in seconds, that a file system is to remain mounted when not in use. The default value is 600 (10 minutes). Equivalent to the -t option in automount.
Verbose mode. Causes you to be notified of non-critical events, suchs as autofs mounts and unmounts. The default value is FALSE. Equivalent to the -v option in automount.
Verbose mode. Causes status messages to be logged to /var/svc/log/system-filesystem-autofs:default.log. (See smf(5).) The default value is FALSE. Equivalent to the -v option in automountd.
Turn on or off browsing for all autofs mount points. The default value is FALSE. Equivalent to the -n option in automountd.
Expands each RPC call and logs it to /var/svc/log/system-filesystem-autofs:default.log. (See smf(5).) The default value, 0, turns off such tracing. Starting with 1, with each higher value, the verbosity of trace output increases.
Environment variables. Each environment variable-value pairing must be on its own line. You can specify multiple such pairings. There are no environment variable settings supplied. For example: AUTOMOUNTD_ENV=DAY=TUES