|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- Internet services and aliases
The services file is a local source of information regarding each service available through the Internet. The services file can be used in conjunction with or instead of other services sources, including the NIS maps “services.byname” and the NIS+ table “services.“ Programs use the getservbyname(3SOCKET) routines to access this information.
The services file contains an entry for each service. Each entry has the form:
service-name port/protocol aliases
This is the official Internet service name.
This field is composed of the port number and protocol through which the service is provided, for instance, 512/tcp.
This is a list of alternate names by which the service might be requested.
Fields can be separated by any number of SPACE and/or TAB characters. A number sign (#) indicates the beginning of a comment; any characters that follow the comment character up to the end of the line are not interpreted by routines which search the file.
Service names may contain any printable character other than a field delimiter, a NEWLINE, or a comment character.
Any changes to a port assignment do not affect the actual port registration of the service.
configuration file for name-service switch
/etc/inet/services is the official SVR4 name of the services file. The symbolic link /etc/services exists for BSD compatibility.