|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- device_maps file
The device_maps file contains access control information about each physical device. Each device is represented by a one line entry of the form:
device-name : device-type : device-list :
This is an arbitrary ASCII string naming the physical device. This field contains no embedded white space or non-printable characters.
This is an arbitrary ASCII string naming the generic device type. This field identifies and groups together devices of like type. This field contains no embedded white space or non-printable characters.
This is a list of the device special files associated with the physical device. This field contains valid device special file path names separated by white space.
The device_maps file is an ASCII file that resides in the /etc/security directory.
Lines in device_maps can end with a `\' to continue an entry on the next line.
Comments may also be included. A `#' makes a comment of all further text until the next NEWLINE not immediately preceded by a `\'.
Leading and trailing blanks are allowed in any of the fields.
The device_maps file must be created by the system administrator bef\ore device allocation is enabled.
This file is owned by root, with a group of sys, and a mode of 0644.
Example 1 A Sample device_maps File
The following is a sample device_maps file:
# scsi tape st1:\ rmt:\ /dev/rst21 /dev/nrst21 /dev/rst5 /dev/nrst5 /dev/rst13 \ /dev/nrst13 /dev/rst29 /dev/nrst29 /dev/rmt/1l /dev/rmt/1m \ /dev/rmt/1 /dev/rmt/1h /dev/rmt/1u /dev/rmt/1ln /dev/rmt/1mn \ /dev/rmt/1n /dev/rmt/1hn /dev/rmt/1un /dev/rmt/1b /dev/rmt/1bn:\
Contains access control information for devices.
See attributes(5) for descriptions of the following attributes:
The functionality described in this man page is available only if Solaris Auditing has been enabled. See bsmconv(1M) for more information.
On systems configured with Trusted Extensions, the functionality is enabled by default. On such systems, the device_allocate(4) file is updated automatically by the system.