|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- specify host's domain name
The file /etc/defaultdomain determines a host's domain name for direct use by the NIS and NIS+ name services. The defaultdomain file is read at boot time and its contents used by the domainname(1M) command. Because of its use by domainname, defaultdomain is also used by the LDAP service (see ldap(1)). Under certain, narrow circumstances (see resolv.conf(4)), because domainname uses defaultdomain, a DNS client can use the contents of defaultdomain.
The contents of defaultdomain consists of a single line containing a host's domain name.
The defaultdomain file is created and modified by Solaris installation and configuration scripts. Only users knowledgeable of name service configuration should edit the file.