|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- configuration file for security policy
The policy.conf file provides the security policy configuration for user-level attributes. Each entry consists of a key/value pair in the form:
The following keys are defined:
Specify the algorithms that are allowed for new passwords and is enforced only in crypt_gensalt(3C).
Specify the algorithm for new passwords that is to be deprecated. For example, to deprecate use of the traditional UNIX algorithm, specify CRYPT_ALGORITHMS_DEPRECATE=__unix__ and change CRYPT_DEFAULT= to another algorithm, such as CRYPT_DEFAULT=1 for BSD and Linux MD5.
Specify the default algorithm for new passwords. The Solaris default is the traditional UNIX algorithm. This is not listed in crypt.conf(4) since it is internal to libc. The reserved name __unix__ is used to refer to it.
Specifies whether a local account is locked after the count of failed logins for a user equals or exceeds the allowed number of retries as defined by RETRIES in /etc/default/login. The default value for users is NO. Individual account overrides are provided by user_attr(4).
Settings for these keys determine the default privileges that users have. (See privileges(5).) If these keys are not set, the default privileges are taken from the inherited set. PRIV_DEFAULT determines the default set on login. PRIV_LIMIT defines the limit set on login. Users can have privileges assigned or taken away through use of user_attr(4). Privileges can also be assigned to profiles, in which case users who have those profiles can exercise the assigned privileges through pfexec(1).
For maximum future compatibility, the privilege specifications should always include basic or all. Privileges should then be removed using negation. See EXAMPLES. By assigning privileges in this way, you avoid a situation where, following an addition of a currently unprivileged operation to the basic privilege set, a user unexpectedly does not have the privileges he needs to perform that now-privileged operation.
Note that removing privileges from the limit set requires extreme care, as any set-uid root program might suddenly fail because it lacks certain privilege(s). Note also that dropping basic privileges from the default privilege set can cause unexpected failure modes in applications.
Specify the default set of profiles granted to all users. This entry is interpreted by chkauthattr(3SECDB) and getexecuser(3SECDB). The value is one or more comma-separated profiles defined in prof_attr(4).
Specify whether to use the newer password semantics, which restrict locking of nologin accounts and unlocking using password-setting.
If this option is set to NO, the following behavior is in effect:
Assigning a new password unlocks a locked account.
nologin accounts are lockable using passwd -l.
New accounts have *LK* in the password field.
passwd -l returns 0 if the account is already locked.
If this option is set to YES, the following behavior is in effect:
Assigning a new password to a locked account replaces the password, but retains the lock.
nologin accounts (see the -N option of passwd(1)) cannot be locked directly. passwd -d followed by passwd -l is required.
New accounts have UP in the password field.
passwd -l returns a non-zero value if nothing changes.
This option is Obsolete and is not present in newer releases. The default for this option is YES.
The key/value pair must appear on a single line, and the key must start the line. Lines starting with # are taken as comments and ignored. Option name comparisons are case-insensitive.
Only one CRYPT_ALGORITHMS_ALLOW or CRYPT_ALGORITHMS_DEPRECATE value can be specified. Whichever is listed first in the file takes precedence. The algorithm specified for CRYPT_DEFAULT must either be specified for CRYPT_ALGORITHMS_ALLOW or not be specified for CRYPT_ALGORITHMS_DEPRECATE. If CRYPT_DEFAULT is not specified, the default is __unix__.
Example 1 Defining a Key/Value Pair
Example 2 Specifying Privileges
As noted above, you should specify privileges through negation, specifying all for PRIV_LIMIT and basic for PRIV_DEFAULT, then subtracting privileges, as shown below.
The first line, above, takes away only the sys_linkdir privilege. The second line takes away only the file_link privilege. These privilege specifications will be unaffected by any future addition of privileges that might occur.
Defines extended user attributes.
Defines policy for the system.
See attributes(5) for descriptions of the following attributes:
The RESTRICTIVE_LOCKING option is Obsolete and is not present in newer releases. The rest of the command is Evolving.
Oracle Solaris 10 8/11 What's New