|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 1/13 Information Library|
- configuration file for the Net-SNMP applications
The file snmp.conf defines how the Net-SNMP applications operate. Tokens that can be put in the file are described in the DIRECTIVES section below.
If you are storing sensitive information, such as passphrases, in snmp.conf, make sure you make the file readable only by user.
Before modifying snmp.conf, make sure to read the snmp_config(4) manual page, which describes the effects of the Net-SNMP configuration files, where they are located, and how they all work together.
The snmp.conf file supports the following directives:
Look for text MIBs to parse in the colon-separated list of directories. If the directive value starts with a plus sign, it prepends this list to the default directory list compiled into the application. Note that the value specified here can be overridden by the MIBDIRS environment variable.
Specifies a colon-separated list of MIB tokens that represent textual MIB files that are to be found and parsed. If the directive value starts with a plus sign, it prepends this list to the default MIB token list compiled into the application. The special keyword of ALL forces all MIBs files found to be read. Note that the value specified here can be overridden by the MIBS environment variable.
Specifies a text MIB file to read and parse, in addition to the list read from the MIBs token. Note that the value specified here can be overridden by the MIBFILES environment variable.
The directory where snmpd and snmptrapd store their persistent data files.
The default port number that all SNMP applications and daemons should use.
The default SNMP version to use. The default value is 3.
The default SNMPv1 and SNMPv2c community string to use. The default value is the empty string, "".
The default SNMPv3 USM security name you want to use for SNMPv3 requests.
The default SNMPv3 context name you want to use.
The default SNMPv3 USM passphrase(s) to use. If it is specified, defPassphrase is used for both authentication and privacy pass phrases.
The SNMPv3 USM authentication type to use. The default value is MD5.
The SNMPv3 USM privacy type to use. Currently, DES is the only possible value.
The SNMPv3 default security level to use. The default is authPriv.
Determines whether to display text MIB parsing errors when commands are run.
Determines whether parsing of MIBs should be strict about comment termination. A double hyphen ("--") terminates a comment if this is true. Many MIBs have broken comments in them, hence this option.
Allow underline characters in MIBs (ordinarily illegal).
Specifies the minimum warning level of the warnings printed by the MIB parser.
Equivalent to -Oe.
Equivalent to -On.
Equivalent to -Ob.
Equivalent to -OE.
Equivalent to -Oq.
Equivalent to -OU.
Equivalent to -OT.
If the value is 1, this directive is equivalent to -Os. If the value is 2, it is equivalent to -OS.
Maps -O options as follows:
-Os=1 -OS=2 -Of=3 -On=4 -Ou=5
The value 6 has no matching -O option. It suppresses output.
Equivalent to -OX.
Disables the validation of values that is done by snmpset(1M) before issuing the request to the agent. Equivalent to -Ir.
Disables the use of DISPLAY-HINT information when parsing indices and values to set. Equivalent to -Ih.
Determines whether commands should dump packets by default.
Turns on debugging for all applications run if set to 1.
Specifies the debugging tokens that should be displayed. See snmpcmd(1M) for debugging usage details.
See attributes(5) for descriptions of the following attributes: