Go to main content

man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

tran_bus_reset(9E)

Name

tran_bus_reset - reset a SCSI bus

Synopsis

#include <sys/scsi/scsi.h> int prefix

tran_bus_reset(dev_info_t *hba_dip, int level);

Interface Level

Solaris DDI

Parameters

hba_dip

The dev_info_t pointer associated with the SCSI HBA.

level

The level of reset required.

Description

The tran_bus_reset() vector in the scsi_hba_tran(9S) structure should be initialized during the HBA driver's attach(9E). It is an HBA entry point to be called when a user initiates a bus reset through device control interfaces.

tran_bus_reset() must reset the SCSI bus without resetting targets.

level will be one of the following:

RESET_BUS

Reset the SCSI bus only, not the targets.

Implementation is hardware specific. If it is not possible to reset the SCSI bus without changing the state and operating mode of the targets, the HBA driver should not initialize this vector or return failure.

Return Values

tran_bus_reset() should return:

1

on success.

0

on failure.

Attributes

See attributes(7) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(7), tran_quiesce(9E), scsi_hba_tran(9S)