|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- Trusted Extensions Zone Manager configuration utility
/usr/sbin/txzonemgr [-c | -d[f]]
The txzonemgr shell script provides a simple, menu-based GUI wizard for creating, installing, initializing, and booting labeled zones on a system on which Trusted Extensions is enabled. The script also provides menu items for networking options, name services options, and making the global zone a client of an existing LDAP server. By default, all zones are configured to use the same name service and IP address as the global zone.
txzonemgr can also perform a limited set of commands in command-line mode instead of GUI mode, by using appropriate options, described below.
txzonemgr is run by roles granted in the Zone Management Rights Profile, or by root in the global zone.
Without options, txzonemgr operates as a menu-based GUI. Using any options will result in command-line operation only. Except as specified below, options cannot be combined.
The following options are supported:
Create default zones. Requires that no zones already exist. The number, names, and attributes of the zones created is subject to change. However, typically a “public” zone and at least one other zone is created.
Destroy all zones. All zones will be halted, uninstalled, and deleted. Prompts for confirmation unless the -f option is also specified.
Force. Can be used with -d to override prompt for confirmation.
No values are returned for GUI mode. For command-line operation, the following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
Solaris Trusted Extensions Administrator's Procedures
If administering zones from JDS, use txzonemgr rather than CDE actions.
txzonemgr uses the zenity command. For details, see the zenity(1) man page, which is not part of the SunOS collection.