JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 1M: System Administration Commands     Oracle Solaris 11 Express 11/10
search filter icon
search icon

Document Information

Preface

Introduction

System Administration Commands - Part 1

System Administration Commands - Part 2

System Administration Commands - Part 3

txzonemgr(1M)

tzreload(1M)

tzselect(1M)

uadmin(1M)

ucodeadm(1M)

ufsdump(1M)

ufsrestore(1M)

umount(1M)

umountall(1M)

umount_smbfs(1M)

unlink(1M)

unshare(1M)

unshareall(1M)

unshare_nfs(1M)

update_drv(1M)

updatehome(1M)

updatemanager(1M)

updatemedia(1M)

useradd(1M)

userdel(1M)

usermod(1M)

utmp2wtmp(1M)

utmpd(1M)

uucheck(1M)

uucico(1M)

uucleanup(1M)

uucpd(1M)

uusched(1M)

Uutry(1M)

uutry(1M)

uuxqt(1M)

vdiskadm(1M)

virsh(1M)

virt-clone(1M)

virt-convert(1M)

virtinfo(1M)

virt-install(1M)

vmstat(1M)

vntsd(1M)

volcopy(1M)

volcopy_ufs(1M)

vrrpadm(1M)

vrrpd(1M)

vscanadm(1M)

vscand(1M)

vtdaemon(1M)

wall(1M)

wanboot_keygen(1M)

wanboot_keymgmt(1M)

wanboot_p12split(1M)

wanbootutil(1M)

wbemadmin(1M)

wbemconfig(1M)

wbemlogviewer(1M)

wcadmin(1M)

whodo(1M)

wificonfig(1M)

wpad(1M)

wracct(1M)

wtmpfix(1M)

wusbadm(1M)

xenconsoled(1M)

xend(1M)

xenstored(1M)

xentop(1M)

xm(1M)

ypbind(1M)

ypinit(1M)

ypmake(1M)

ypmap2src(1M)

yppasswdd(1M)

yppoll(1M)

yppush(1M)

ypserv(1M)

ypset(1M)

ypstart(1M)

ypstop(1M)

ypupdated(1M)

ypxfr(1M)

ypxfr_1perday(1M)

ypxfr_1perhour(1M)

ypxfr_2perday(1M)

ypxfrd(1M)

zdb(1M)

zdump(1M)

zfs(1M)

zic(1M)

zoneadm(1M)

zoneadmd(1M)

zonecfg(1M)

zonestatd(1M)

zpool(1M)

zstreamdump(1M)

zuludaemon(1M)

vrrpadm

- VRRP administration tool

Synopsis

vrrpadm create-router -V vrid -l link -A inet | inet6
        [-p priority] [-i adv_interval] [-o flags] router_name
vrrpadm delete-router router_name
vrrpadm disable-router router_name
vrrpadm enable-router router_name
vrrpadm modify-router [-p priority] [-i adv_interval]
        [-o flags] [router_name]
vrrpadm show-router [-P | -x] [-p] [-o field[,...]] [router_name]

Description

The vrrpadm command is used to administer the VRRP (Virtual Router Redundancy Protocol) service in a system.

VRRP specifies an election protocol that dynamically assigns responsibility for a virtual router to one of the VRRP routers within a LAN. At a given moment, only one VRRP router controls the IPv4 or IPv6 virtual address(es) associated with a virtual router (known as the master), and forwards packets sent to these IP addresses. The election process provides dynamic failover of the forwarding responsibility should the master become unavailable.

Each vrrpadm subcommand operates on a VRRP router, which is identified by a name given by the administrator. VRRP routers with the same VRID and address family within a LAN comprise a virtual router, which protects a set of virtual IP addresses.

A system can have multiple VRRP routers; each belongs to a different virtual router.

Sub-commands

The following subcommands are supported. Note that all subcommands but show-router require the solaris.network.vrrp authorization. The show-router subcommand does not require special authorizations.

vrrpadm create-router -V vrid -l link -A inet | inet6 [-p priority] [-i adv_interval] [-o flags] router_name

Create a VRRP router with a specified configuration.

-A inet | inet6, --address_family=inet | inet6

Address family. Either IPv4 or IPv6.

-i adv_interval, --adv_interval=adv_interval

The advertisement interval in milliseconds. Default is 1000 (one second). The valid interval range is 10-40950.

-l link, --link=link

The data link on which the VRRP router is configured. This determines the LAN this VRRP router is running in. The data-link can be a physical link, a VLAN, or an aggregation.

-o flags, --flags=flags

The preempt and accept modes, delimited by a comma. Values can be:

  • preempt

  • un_preempt

  • accept

  • noaccept

By default both modes are set to true.

The preempt mode controls whether an enabled higher priority backup router preempts a lower priority master router. If preempt mode is true, then the preemption is allowed; otherwise, preemption is prohibited. Note that the preempt mode must be true if the VRRP router is the owner of the virtual IP addresses.

The accept mode controls the local packet acceptance of the virtual IP addresses. If accept mode is true, the master must accept packets sent to the virtual IP addresses. If accept mode is false, the master does not accept those packets, although it does respond to ARP requests or ND Solicitations and Advertisement for those non-accepted virtual IP addresses. It also must forward packets for the router specified in this subcommand. Note that accept mode must be true if the VRRP router is the owner of the virtual IP addresses. An example of syntax for this option:

-o preempt,no_accept
-p priority, --priority=priority

The priority of the specified VRRP router used in master selection. The higher the value, the greater the possibility the router is selected as the master.

The default value is 255, which indicates the specified VRRP router is the IP Address Owner and owns all the virtual IP addresses. An IP Address Owner will respond to the packets addressed to one of the virtual IP addresses for ICMP pings, TCP connections, and so forth.

The range 1-254 is available for VRRP routers backing up a virtual router. Master selection is weighted toward the VRRP router with the higher priority.

-V vrid, --VRID=vrid

The virtual router identifier (VRID). Together with the address family, it identifies a virtual router within a LAN.

router_name

The name of a VRRP router. This name is used to identify a VRRP router in other vrrpadm subcommands.

The maximum length of a valid router name is 31 characters. Legal characters are alphanumeric (a-z, A-Z, 0-9) and the underscore ('_').

vrrpadm delete-router router_name

Delete the VRRP router identified by router_name.

vrrpadm disable-router router_name

Disable the virtual router identified by router_name. Once the router is disabled, it will stop participating in the master selection process in the virtual router.

vrrpadm enable-router router_name

Re-enable the virtual router identified by router_name that was disabled. The router will resume participating in the master selection process in the virtual router.

vrrpadm modify-router [-p priority] [-i adv_interval] [-o flags] [router_name]

Modify the configuration of the VRRP router identified by router_name. Only the priority, the advertisement interval, the preempt mode, and the accept mode can be modified.

-p priority, --priority=priority

The new priority of this VRRP router.

-i adv_interval, --adv_interval=adv_interval

The new advertisement interval.

-o flags, --flags=flags

The new preempt and accept modes. Either one or both can be specified. If both are specified, they are delimited by a comma. For example:

-o preempt,no_accept
vrrpadm show-router [-P | -x] [-p] [-o field[,...]] [router_name]

Display the information for the VRRP router identified by router_name. If no router_name is specified, display information for all the VRRP routers on the system.

By default (with no options), the following fields are displayed:

NAME

The name of the VRRP router.

VRID

The VRID of the VRRP router.

LINK

The data link on which the VRRP router is created.

AF

he address family of the VRRP router, either IPv4 or IPv6.

PRIO

The priority of this VRRP router used in master selection.

ADV_INTV

The advertisement interval, in milliseconds.

STATE

The current state of the VRRP router, INIT (Initialize), BACK (Backup), or MAST (Master).

MODE

A set of flags associated with the VRRP router. Possible values are:

e

The router has been enabled.

p

Preempt mode is true.

a

Accept mode is true.

o

Virtual address owner.

VNIC

The VRRP VNIC created for this VRRP router.

Note that the name of the VNIC can change over time unless the router is enabled.

The show-router subcommand has the following options:

-x, --extended

Display additional information of the given VRRP router:

PRIMARY_IP

The primary IP address selected by the VRRP router.

VIRTUAL_IPS

The virtual IP addresses configured on the VRRP router.

PRV_STAT

The previous state of the VRRP router.

STAT_LAST

Time since the last state transition.

-P, --peer

Display information for the backup VRRP router. This option is meaningful only when the VRRP router is in the backup state.

The following fields are displayed:

NAME

The name of the VRRP router.

PEER

The primary IP address of the peer VRRP router.

P_PRIO

The priority of the peer VRRP router contained in the advertisement received from the peer.

P_INTV

The advertisement interval (in milliseconds) contained in advertisements received from the peer.

P_ADV_LAST

Time since last received advertisement from the peer.

MASTER_DOWN_INT

Time interval (in milliseconds) after which to declare Master down.

-p, --parseable

Display the VRRP router information in the machine parseable format.

-o field[,...], --output=field

A case-insensitive, comma-separated list of output fields to display. The field name must be one of the fields listed above, or the special value all to display all fields. By default (without -o), vrrpadm show displays all fields.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/network/routing/vrrp
Interface Stability
Committed

See Also

dladm(1M), vrrpd(1M), attributes(5)