|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- ZFS debugger
The zdb command is used by support engineers to diagnose failures and gather statistics. Since the ZFS file system is always consistent on disk and is self-repairing, zdb should only be run under the direction by a support engineer.
If no arguments are specified, zdb, performs basic consistency checks on the pool and associated datasets, and report any problems detected.
Any options supported by this command are internal to Sun and subject to change at any time.
The following exit values are returned:
The pool is consistent.
An error was detected.
Invalid command line options were specified.
See attributes(5) for descriptions of the following attributes: