|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- uucp spool directory clean-up
/usr/lib/uucp/uucleanup [-Ctime] [-Dtime] [-mstring] [-otime] [-ssystem] [-Wtime] [-xdebug-level] [-Xtime]
uucleanup will scan the spool directories for old files and take appropriate action to remove them in a useful way:
Inform the requester of send/receive requests for systems that can not be reached.
Return undeliverable mail to the sender.
Deliver rnews files addressed to the local system.
Remove all other files.
In addition, there is a provision to warn users of requests that have been waiting for a given number of days (default 1 day). Note: uucleanup will process as if all option times were specified to the default values unless time is specifically set.
This program is typically started by the shell uudemon.cleanup, which should be started by cron(1M).
Remove any C. files greater or equal to time days old and send appropriate information to the requester (default 7 days).
Remove any D. files greater or equal to time days old, make an attempt to deliver mail messages, and execute rnews when appropriate (default 7 days).
Include string in the warning message generated by the -W option. The default line is "See your local administrator to locate the problem".
Delete other files whose age is more than time days (default 2 days).
Execute for system spool directory only.
Any C. files equal to time days old will cause a mail message to be sent to the requester warning about the delay in contacting the remote. The message includes the JOBID, and in the case of mail, the mail message. The administrator may include a message line telling whom to call to check the problem (-m option) (default 1 day).
Produce debugging output on standard ouput. debug-level is a single digit between 0 and 9; higher numbers give more detailed debugging information. (This option may not be available on all systems.)
Any X. files greater or equal to time days old will be removed. The D. files are probably not present (if they were, the X. could get executed). But if there are D. files, they will be taken care of by D. processing (default 2 days).
directory with commands used by uucleanup internally
See attributes(5) for descriptions of the following attributes: