|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- force propagation of changed NIS map
/usr/lib/netsvc/yp/yppush [-v] [-h host] [-d domain] [-p #parallel-xfrs] mapname
yppush copies a new version of a Network Information Service (NIS) map from the master NIS server to the slave NIS servers. It is normally run only on the master NIS server by the Makefile in /var/yp after the master databases are changed. It first constructs a list of NIS server hosts by reading the NIS ypservers map within the domain. Keys within the ypservers map are the ASCII names of the machines on which the NIS servers run.
A “transfer map” request is sent to the NIS server at each host, along with the information needed by the transfer agent (the program that actually moves the map) to call back the yppush. When the attempt has completed (successfully or not), and the transfer agent has sent yppush a status message, the results can be printed to stdout. Messages are also printed when a transfer is not possible, for instance, when the request message is undeliverable, or when the timeout period on responses has expired.
The following options are supported:
Specifies a domain.
Propagates only to the named host.
Allows the specified number of map transfers to occur in parallel.
Verbose. This prints messages when each server is called, and for each response. If this flag is omitted, only error messages are printed.
Directory where NIS configuration files reside.
Map containing list of NIS servers to bind to when running in server mode.
See attributes(5) for descriptions of the following attributes:
The Network Information Service (NIS) was formerly known as Sun Yellow Pages (YP). The functionality of the two remains the same; only the name has changed. The name Yellow Pages is a registered trademark in the United Kingdom of British Telecommunications PLC, and must not be used without permission.
In the current implementation (version 2 NIS protocol), the transfer agent is ypxfr(1M), which is started by the ypserv program. If yppush detects that it is speaking to a version 1 NIS protocol server, it uses the older protocol, sending a version 1 YPPROC_GET request and issues a message to that effect. Unfortunately, there is no way of knowing if or when the map transfer is performed for version 1 servers. yppush prints a message saying that an “old-style” message has been sent. The system administrator should later check to see that the transfer has actually taken place.