|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- insert and extract keys
/usr/lib/inet/wanboot/keymgmt -i -k key_file -s keystore -o type=keytype
/usr/lib/inet/wanboot/keymgmt -x -f outfile -s keystore -o type=keytype
The keymgmt utility has two purposes:
To take a raw key, stored in key_file, and insert it in the repository specified by keystore.
To extract a key of a specified type from the repository specified by keystore, depositing it in outfile.
outfile will be created if it does not already exist. The type of key being added or extracted is specified by keytype and may have one of four values: 3des, aes, rsa, or sha1 (the last used by HMAC SHA-1). When extracting a key, the first key with an OID matching the supplied type is used.
The following arguments are supported:
Used in conjunction with -k to insert a raw key in keystore.
Used to specify a file to receive an extracted key.
Used in conjunction with -i to specify the file in which a raw key is stored. This key will be inserted in keystore.
Specifies the type of key being inserted or extracted. Must be one of 3des, aes, rsa, or sha1.
Specifies a repository in which a key will be inserted or from which a key will be extracted.
Used in conjunction with -f to extract a key of a specified type and deposit it in outfile.
An error occurred.
See attributes(5) for descriptions of the following attributes:
ITU-T Recommendation X.208