|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- parse Function Identification tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_FUNCID(client_handle_t ch, tuple_t *tu, cistpl_funcid_t *cf);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_funcid_t structure which contains the parsed CISTPL_FUNCID tuple information upon return from this function.
This function parses the Function Identification tuple, CISTPL_FUNCID, into a form usable by PC Card drivers.
The CISTPL_FUNCID tuple is used to describe information about the functionality provided by a PC Card. Information is also provided to enable system utilities to decide if the PC Card should be configured during system initialization. If additional function specific information is available, one or more function extension tuples of type CISTPL_FUNCE follow this tuple (see csx_Parse_CISTPL_FUNCE(9F)).
The structure members of cistpl_funcid_t are:
uint32_t function; /* PC Card function code */ uint32_t sysinit; /* system initialization mask */
The fields are defined as follows:
This is the function type for CISTPL_FUNCID:
Vendor-specific multifunction card
Serial I/O port
Parallel printer port
Fixed disk, silicon or removable
Local Area Network adapter
Auto Incrementing Mass Storage
This field is bit-mapped and defined as follows:
POST should attempt configure
Map ROM during sys init
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA