|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- set up a user mapping using seg_dev
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_segmap(dev_t dev, off_t offset, struct as *asp, caddr_t *addrp, off_t len, uint_t prot, uint_t maxprot, uint_t flags, cred_t *credp);
int ddi_segmap_setup(dev_t dev, off_t offset, struct as *asp, caddr_t *addrp, off_t len, uint_t prot, uint_t maxprot, uint_t flags, cred_t *credp, ddi_device_acc_attr_t *accattrp, uint_t rnumber);
The device whose memory is to be mapped.
The offset within device memory at which the mapping begins.
An opaque pointer to the user address space into which the device memory should be mapped.
Pointer to the starting address within the user address space to which the device memory should be mapped.
Length (in bytes) of the memory to be mapped.
A bit field that specifies the protections. Some combinations of possible settings are:
Read access is desired.
Write access is desired.
Execute access is desired.
User-level access is desired (the mapping is being done as a result of a mmap(2) system call).
All access is desired.
Maximum protection flag possible for attempted mapping (the PROT_WRITE bit may be masked out if the user opened the special file read-only). If (maxprot & prot) != prot then there is an access violation.
Flags indicating type of mapping. Possible values are (other bits may be set):
Changes are private.
Changes should be shared.
The user specified an address in *addrp rather than letting the system pick and address.
Pointer to user credential structure.
Pointer to a ddi_device_acc_attr(9S) structure which contains the device access attributes to apply to this mapping.
Index number to the register address space set.
Future releases of Solaris will provide this function for binary and source compatibility. However, for increased functionality, use ddi_devmap_segmap(9F) instead. See ddi_devmap_segmap(9F) for details.
ddi_segmap( ) and ddi_segmap_setup() set up user mappings to device space. When setting up the mapping, the ddi_segmap( ) and ddi_segmap_setup() routines call the mmap(9E) entry point to validate the range to be mapped. When a user process accesses the mapping, the drivers mmap(9E) entry point is again called to retrieve the page frame number that needs to be loaded. The mapping translations for that page are then loaded on behalf of the driver by the DDI framework.
ddi_segmap() is typically used as the segmap(9E) entry in the cb_ops(9S) structure for those devices that do not choose to provide their own segmap(9E) entry point. However, some drivers may have their own segmap(9E) entry point to do some initial processing on the parameters and then call ddi_segmap() to establish the default memory mapping.
ddi_segmap_setup() is used in the drivers segmap(9E) entry point to set up the mapping and assign device access attributes to that mapping. rnumber specifies the register set representing the range of device memory being mapped. See ddi_device_acc_attr(9S) for details regarding what device access attributes are available.
ddi_segmap() and ddi_segmap_setup() return the following values:
An error occurred. In particular, they return ENXIO if the range to be mapped is invalid.
ddi_segmap() and ddi_segmap_setup() can be called from user or kernel context only.
See attributes(5) for a description of the following attributes: