JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Kernel Functions     Oracle Solaris 10 8/11 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Kernel Functions for Drivers

adjmsg(9F)

allocb(9F)

allocb_tmpl(9F)

aminphys(9F)

anocancel(9F)

aphysio(9F)

ASSERT(9F)

assert(9F)

atomic_add_16(9F)

atomic_add_16_nv(9F)

atomic_add_32(9F)

atomic_add_32_nv(9F)

atomic_add_64(9F)

atomic_add_64_nv(9F)

atomic_add_8(9F)

atomic_add_8_nv(9F)

atomic_add(9F)

atomic_add_char(9F)

atomic_add_char_nv(9F)

atomic_add_int(9F)

atomic_add_int_nv(9F)

atomic_add_long(9F)

atomic_add_long_nv(9F)

atomic_add_ptr(9F)

atomic_add_ptr_nv(9F)

atomic_add_short(9F)

atomic_add_short_nv(9F)

atomic_and_16(9F)

atomic_and_16_nv(9F)

atomic_and_32(9F)

atomic_and_32_nv(9F)

atomic_and_64(9F)

atomic_and_64_nv(9F)

atomic_and_8(9F)

atomic_and_8_nv(9F)

atomic_and(9F)

atomic_and_uchar(9F)

atomic_and_uchar_nv(9F)

atomic_and_uint(9F)

atomic_and_uint_nv(9F)

atomic_and_ulong(9F)

atomic_and_ulong_nv(9F)

atomic_and_ushort(9F)

atomic_and_ushort_nv(9F)

atomic_bits(9F)

atomic_cas_16(9F)

atomic_cas_32(9F)

atomic_cas_64(9F)

atomic_cas_8(9F)

atomic_cas(9F)

atomic_cas_ptr(9F)

atomic_cas_uchar(9F)

atomic_cas_uint(9F)

atomic_cas_ulong(9F)

atomic_cas_ushort(9F)

atomic_clear_long_excl(9F)

atomic_dec_16(9F)

atomic_dec_16_nv(9F)

atomic_dec_32(9F)

atomic_dec_32_nv(9F)

atomic_dec_64(9F)

atomic_dec_64_nv(9F)

atomic_dec_8(9F)

atomic_dec_8_nv(9F)

atomic_dec(9F)

atomic_dec_ptr(9F)

atomic_dec_ptr_nv(9F)

atomic_dec_uchar(9F)

atomic_dec_uchar_nv(9F)

atomic_dec_uint(9F)

atomic_dec_uint_nv(9F)

atomic_dec_ulong(9F)

atomic_dec_ulong_nv(9F)

atomic_dec_ushort(9F)

atomic_dec_ushort_nv(9F)

atomic_inc_16(9F)

atomic_inc_16_nv(9F)

atomic_inc_32(9F)

atomic_inc_32_nv(9F)

atomic_inc_64(9F)

atomic_inc_64_nv(9F)

atomic_inc_8(9F)

atomic_inc_8_nv(9F)

atomic_inc(9F)

atomic_inc_ptr(9F)

atomic_inc_ptr_nv(9F)

atomic_inc_uchar(9F)

atomic_inc_uchar_nv(9F)

atomic_inc_uint(9F)

atomic_inc_uint_nv(9F)

atomic_inc_ulong(9F)

atomic_inc_ulong_nv(9F)

atomic_inc_ushort(9F)

atomic_inc_ushort_nv(9F)

atomic_ops(9F)

atomic_or_16(9F)

atomic_or_16_nv(9F)

atomic_or_32(9F)

atomic_or_32_nv(9F)

atomic_or_64(9F)

atomic_or_64_nv(9F)

atomic_or_8(9F)

atomic_or_8_nv(9F)

atomic_or(9F)

atomic_or_uchar(9F)

atomic_or_uchar_nv(9F)

atomic_or_uint(9F)

atomic_or_uint_nv(9F)

atomic_or_ulong(9F)

atomic_or_ulong_nv(9F)

atomic_or_ushort(9F)

atomic_or_ushort_nv(9F)

atomic_set_long_excl(9F)

atomic_swap_16(9F)

atomic_swap_32(9F)

atomic_swap_64(9F)

atomic_swap_8(9F)

atomic_swap(9F)

atomic_swap_ptr(9F)

atomic_swap_uchar(9F)

atomic_swap_uint(9F)

atomic_swap_ulong(9F)

atomic_swap_ushort(9F)

backq(9F)

bcanput(9F)

bcanputnext(9F)

bcmp(9F)

bcopy(9F)

bioclone(9F)

biodone(9F)

bioerror(9F)

biofini(9F)

bioinit(9F)

biomodified(9F)

bioreset(9F)

biosize(9F)

biowait(9F)

bp_copyin(9F)

bp_copyout(9F)

bp_mapin(9F)

bp_mapout(9F)

btop(9F)

btopr(9F)

bufcall(9F)

bzero(9F)

canput(9F)

canputnext(9F)

clrbuf(9F)

cmn_err(9F)

condvar(9F)

copyb(9F)

copyin(9F)

copymsg(9F)

copyout(9F)

crgetgid(9F)

crgetgroups(9F)

crgetngroups(9F)

crgetrgid(9F)

crgetruid(9F)

crgetsgid(9F)

crgetsuid(9F)

crgetuid(9F)

crgetzoneid(9F)

csx_AccessConfigurationRegister(9F)

csx_ConvertSize(9F)

csx_ConvertSpeed(9F)

csx_CS_DDI_Info(9F)

csx_DeregisterClient(9F)

csx_DupHandle(9F)

csx_Error2Text(9F)

csx_Event2Text(9F)

csx_FreeHandle(9F)

csx_Get16(9F)

csx_Get32(9F)

csx_Get64(9F)

csx_Get8(9F)

csx_GetEventMask(9F)

csx_GetFirstClient(9F)

csx_GetFirstTuple(9F)

csx_GetHandleOffset(9F)

csx_GetMappedAddr(9F)

csx_GetNextClient(9F)

csx_GetNextTuple(9F)

csx_GetStatus(9F)

csx_GetTupleData(9F)

csx_MakeDeviceNode(9F)

csx_MapLogSocket(9F)

csx_MapMemPage(9F)

csx_ModifyConfiguration(9F)

csx_ModifyWindow(9F)

csx_Parse_CISTPL_BATTERY(9F)

csx_Parse_CISTPL_BYTEORDER(9F)

csx_Parse_CISTPL_CFTABLE_ENTRY(9F)

csx_Parse_CISTPL_CONFIG(9F)

csx_Parse_CISTPL_DATE(9F)

csx_Parse_CISTPL_DEVICE(9F)

csx_Parse_CISTPL_DEVICE_A(9F)

csx_Parse_CISTPL_DEVICEGEO(9F)

csx_Parse_CISTPL_DEVICEGEO_A(9F)

csx_Parse_CISTPL_DEVICE_OA(9F)

csx_Parse_CISTPL_DEVICE_OC(9F)

csx_Parse_CISTPL_FORMAT(9F)

csx_Parse_CISTPL_FUNCE(9F)

csx_Parse_CISTPL_FUNCID(9F)

csx_Parse_CISTPL_GEOMETRY(9F)

csx_Parse_CISTPL_JEDEC_A(9F)

csx_Parse_CISTPL_JEDEC_C(9F)

csx_Parse_CISTPL_LINKTARGET(9F)

csx_Parse_CISTPL_LONGLINK_A(9F)

csx_Parse_CISTPL_LONGLINK_C(9F)

csx_Parse_CISTPL_LONGLINK_MFC(9F)

csx_Parse_CISTPL_MANFID(9F)

csx_Parse_CISTPL_ORG(9F)

csx_Parse_CISTPL_SPCL(9F)

csx_Parse_CISTPL_SWIL(9F)

csx_Parse_CISTPL_VERS_1(9F)

csx_Parse_CISTPL_VERS_2(9F)

csx_ParseTuple(9F)

csx_Put16(9F)

csx_Put32(9F)

csx_Put64(9F)

csx_Put8(9F)

csx_RegisterClient(9F)

csx_ReleaseConfiguration(9F)

csx_ReleaseIO(9F)

csx_ReleaseIRQ(9F)

csx_ReleaseSocketMask(9F)

csx_ReleaseWindow(9F)

csx_RemoveDeviceNode(9F)

csx_RepGet16(9F)

csx_RepGet32(9F)

csx_RepGet64(9F)

csx_RepGet8(9F)

csx_RepPut16(9F)

csx_RepPut32(9F)

csx_RepPut64(9F)

csx_RepPut8(9F)

csx_RequestConfiguration(9F)

csx_RequestIO(9F)

csx_RequestIRQ(9F)

csx_RequestSocketMask(9F)

csx_RequestWindow(9F)

csx_ResetFunction(9F)

csx_SetEventMask(9F)

csx_SetHandleOffset(9F)

csx_ValidateCIS(9F)

cv_broadcast(9F)

cv_destroy(9F)

cv_init(9F)

cv_signal(9F)

cv_timedwait(9F)

cv_timedwait_sig(9F)

cv_wait(9F)

cv_wait_sig(9F)

datamsg(9F)

DB_BASE(9F)

DB_LIM(9F)

DB_REF(9F)

DB_TYPE(9F)

ddi_add_event_handler(9F)

ddi_add_intr(9F)

ddi_add_softintr(9F)

ddi_binding_name(9F)

ddi_btop(9F)

ddi_btopr(9F)

ddi_can_receive_sig(9F)

ddi_cb_register(9F)

ddi_cb_unregister(9F)

ddi_check_acc_handle(9F)

ddi_check_dma_handle(9F)

ddi_copyin(9F)

ddi_copyout(9F)

ddi_create_minor_node(9F)

ddi_cred(9F)

ddi_device_copy(9F)

ddi_device_zero(9F)

ddi_devid_compare(9F)

ddi_devid_free(9F)

ddi_devid_get(9F)

ddi_devid_init(9F)

ddi_devid_register(9F)

ddi_devid_sizeof(9F)

ddi_devid_str_decode(9F)

ddi_devid_str_encode(9F)

ddi_devid_str_free(9F)

ddi_devid_unregister(9F)

ddi_devid_valid(9F)

ddi_dev_is_needed(9F)

ddi_dev_is_sid(9F)

ddi_devmap_segmap(9F)

ddi_dev_nintrs(9F)

ddi_dev_nregs(9F)

ddi_dev_regsize(9F)

ddi_dev_report_fault(9F)

ddi_dma_addr_bind_handle(9F)

ddi_dma_addr_setup(9F)

ddi_dma_alloc_handle(9F)

ddi_dma_buf_bind_handle(9F)

ddi_dma_buf_setup(9F)

ddi_dma_burstsizes(9F)

ddi_dma_coff(9F)

ddi_dma_curwin(9F)

ddi_dma_devalign(9F)

ddi_dmae_1stparty(9F)

ddi_dmae(9F)

ddi_dmae_alloc(9F)

ddi_dmae_disable(9F)

ddi_dmae_enable(9F)

ddi_dmae_getattr(9F)

ddi_dmae_getcnt(9F)

ddi_dmae_getlim(9F)

ddi_dmae_prog(9F)

ddi_dmae_release(9F)

ddi_dmae_stop(9F)

ddi_dma_free(9F)

ddi_dma_free_handle(9F)

ddi_dma_get_attr(9F)

ddi_dma_getwin(9F)

ddi_dma_htoc(9F)

ddi_dma_mem_alloc(9F)

ddi_dma_mem_free(9F)

ddi_dma_movwin(9F)

ddi_dma_nextcookie(9F)

ddi_dma_nextseg(9F)

ddi_dma_nextwin(9F)

ddi_dma_numwin(9F)

ddi_dma_segtocookie(9F)

ddi_dma_set_sbus64(9F)

ddi_dma_setup(9F)

ddi_dma_sync(9F)

ddi_dma_unbind_handle(9F)

ddi_driver_major(9F)

ddi_driver_name(9F)

ddi_enter_critical(9F)

ddi_exit_critical(9F)

ddi_ffs(9F)

ddi_fls(9F)

ddi_fm_acc_err_clear(9F)

ddi_fm_acc_err_get(9F)

ddi_fm_capable(9F)

ddi_fm_dma_err_clear(9F)

ddi_fm_dma_err_get(9F)

ddi_fm_ereport_post(9F)

ddi_fm_fini(9F)

ddi_fm_handler_register(9F)

ddi_fm_handler_unregister(9F)

ddi_fm_init(9F)

ddi_fm_service_impact(9F)

ddi_get16(9F)

ddi_get32(9F)

ddi_get64(9F)

ddi_get8(9F)

ddi_getb(9F)

ddi_get_cred(9F)

ddi_get_devstate(9F)

ddi_get_driver_private(9F)

ddi_get_eventcookie(9F)

ddi_get_iblock_cookie(9F)

ddi_getiminor(9F)

ddi_get_instance(9F)

ddi_get_kt_did(9F)

ddi_getl(9F)

ddi_get_lbolt64(9F)

ddi_get_lbolt(9F)

ddi_getll(9F)

ddi_getlongprop(9F)

ddi_getlongprop_buf(9F)

ddi_get_name(9F)

ddi_get_parent(9F)

ddi_get_pid(9F)

ddi_getprop(9F)

ddi_getproplen(9F)

ddi_get_soft_iblock_cookie(9F)

ddi_get_soft_state(9F)

ddi_get_time(9F)

ddi_getw(9F)

ddi_in_panic(9F)

ddi_intr_add_handler(9F)

ddi_intr_add_softint(9F)

ddi_intr_alloc(9F)

ddi_intr_block_disable(9F)

ddi_intr_block_enable(9F)

ddi_intr_clr_mask(9F)

ddi_intr_disable(9F)

ddi_intr_dup_handler(9F)

ddi_intr_enable(9F)

ddi_intr_free(9F)

ddi_intr_get_cap(9F)

ddi_intr_get_hilevel_pri(9F)

ddi_intr_get_navail(9F)

ddi_intr_get_nintrs(9F)

ddi_intr_get_pending(9F)

ddi_intr_get_pri(9F)

ddi_intr_get_softint_pri(9F)

ddi_intr_get_supported_types(9F)

ddi_intr_hilevel(9F)

ddi_intr_remove_handler(9F)

ddi_intr_remove_softint(9F)

ddi_intr_set_cap(9F)

ddi_intr_set_mask(9F)

ddi_intr_set_nreq(9F)

ddi_intr_set_pri(9F)

ddi_intr_set_softint_pri(9F)

ddi_intr_trigger_softint(9F)

ddi_io_get16(9F)

ddi_io_get32(9F)

ddi_io_get8(9F)

ddi_io_getb(9F)

ddi_io_getl(9F)

ddi_io_getw(9F)

ddi_iomin(9F)

ddi_iopb_alloc(9F)

ddi_iopb_free(9F)

ddi_io_put16(9F)

ddi_io_put32(9F)

ddi_io_put8(9F)

ddi_io_putb(9F)

ddi_io_putl(9F)

ddi_io_putw(9F)

ddi_io_rep_get16(9F)

ddi_io_rep_get32(9F)

ddi_io_rep_get8(9F)

ddi_io_rep_getb(9F)

ddi_io_rep_getl(9F)

ddi_io_rep_getw(9F)

ddi_io_rep_put16(9F)

ddi_io_rep_put32(9F)

ddi_io_rep_put8(9F)

ddi_io_rep_putb(9F)

ddi_io_rep_putl(9F)

ddi_io_rep_putw(9F)

ddi_log_sysevent(9F)

ddi_map_regs(9F)

ddi_mem_alloc(9F)

ddi_mem_free(9F)

ddi_mem_get16(9F)

ddi_mem_get32(9F)

ddi_mem_get64(9F)

ddi_mem_get8(9F)

ddi_mem_getb(9F)

ddi_mem_getl(9F)

ddi_mem_getll(9F)

ddi_mem_getw(9F)

ddi_mem_put16(9F)

ddi_mem_put32(9F)

ddi_mem_put64(9F)

ddi_mem_put8(9F)

ddi_mem_putb(9F)

ddi_mem_putl(9F)

ddi_mem_putll(9F)

ddi_mem_putw(9F)

ddi_mem_rep_get16(9F)

ddi_mem_rep_get32(9F)

ddi_mem_rep_get64(9F)

ddi_mem_rep_get8(9F)

ddi_mem_rep_getb(9F)

ddi_mem_rep_getl(9F)

ddi_mem_rep_getll(9F)

ddi_mem_rep_getw(9F)

ddi_mem_rep_put16(9F)

ddi_mem_rep_put32(9F)

ddi_mem_rep_put64(9F)

ddi_mem_rep_put8(9F)

ddi_mem_rep_putb(9F)

ddi_mem_rep_putl(9F)

ddi_mem_rep_putll(9F)

ddi_mem_rep_putw(9F)

ddi_mmap_get_model(9F)

ddi_model_convert_from(9F)

ddi_node_name(9F)

ddi_no_info(9F)

ddi_peek16(9F)

ddi_peek32(9F)

ddi_peek64(9F)

ddi_peek8(9F)

ddi_peek(9F)

ddi_peekc(9F)

ddi_peekd(9F)

ddi_peekl(9F)

ddi_peeks(9F)

ddi_periodic_add(9F)

ddi_periodic_delete(9F)

ddi_poke16(9F)

ddi_poke32(9F)

ddi_poke64(9F)

ddi_poke8(9F)

ddi_poke(9F)

ddi_pokec(9F)

ddi_poked(9F)

ddi_pokel(9F)

ddi_pokes(9F)

ddi_prop_create(9F)

ddi_prop_exists(9F)

ddi_prop_free(9F)

ddi_prop_get_int64(9F)

ddi_prop_get_int(9F)

ddi_prop_lookup(9F)

ddi_prop_lookup_byte_array(9F)

ddi_prop_lookup_int64_array(9F)

ddi_prop_lookup_int_array(9F)

ddi_prop_lookup_string(9F)

ddi_prop_lookup_string_array(9F)

ddi_prop_modify(9F)

ddi_prop_op(9F)

ddi_prop_remove(9F)

ddi_prop_remove_all(9F)

ddi_prop_undefine(9F)

ddi_prop_update(9F)

ddi_prop_update_byte_array(9F)

ddi_prop_update_int64(9F)

ddi_prop_update_int64_array(9F)

ddi_prop_update_int(9F)

ddi_prop_update_int_array(9F)

ddi_prop_update_string(9F)

ddi_prop_update_string_array(9F)

ddi_ptob(9F)

ddi_put16(9F)

ddi_put32(9F)

ddi_put64(9F)

ddi_put8(9F)

ddi_putb(9F)

ddi_putl(9F)

ddi_putll(9F)

ddi_putw(9F)

ddi_regs_map_free(9F)

ddi_regs_map_setup(9F)

ddi_remove_event_handler(9F)

ddi_remove_intr(9F)

ddi_remove_minor_node(9F)

ddi_remove_softintr(9F)

ddi_removing_power(9F)

ddi_rep_get16(9F)

ddi_rep_get32(9F)

ddi_rep_get64(9F)

ddi_rep_get8(9F)

ddi_rep_getb(9F)

ddi_rep_getl(9F)

ddi_rep_getll(9F)

ddi_rep_getw(9F)

ddi_report_dev(9F)

ddi_rep_put16(9F)

ddi_rep_put32(9F)

ddi_rep_put64(9F)

ddi_rep_put8(9F)

ddi_rep_putb(9F)

ddi_rep_putl(9F)

ddi_rep_putll(9F)

ddi_rep_putw(9F)

ddi_root_node(9F)

ddi_segmap(9F)

ddi_segmap_setup(9F)

ddi_set_driver_private(9F)

ddi_slaveonly(9F)

ddi_soft_state(9F)

ddi_soft_state_fini(9F)

ddi_soft_state_free(9F)

ddi_soft_state_init(9F)

ddi_soft_state_zalloc(9F)

ddi_strtol(9F)

ddi_strtoll(9F)

ddi_strtoul(9F)

ddi_strtoull(9F)

ddi_taskq_create(9F)

ddi_taskq_destroy(9F)

ddi_taskq_dispatch(9F)

ddi_taskq_resume(9F)

ddi_taskq_suspend(9F)

ddi_taskq_wait(9F)

ddi_trigger_softintr(9F)

ddi_umem_alloc(9F)

ddi_umem_free(9F)

ddi_umem_iosetup(9F)

ddi_umem_lock(9F)

ddi_umem_unlock(9F)

ddi_unmap_regs(9F)

delay(9F)

desballoc(9F)

devmap_default_access(9F)

devmap_devmem_setup(9F)

devmap_do_ctxmgt(9F)

devmap_load(9F)

devmap_set_ctx_timeout(9F)

devmap_setup(9F)

devmap_umem_setup(9F)

devmap_unload(9F)

disksort(9F)

dlbindack(9F)

dlerrorack(9F)

dlokack(9F)

dlphysaddrack(9F)

dluderrorind(9F)

drv_getparm(9F)

drv_hztousec(9F)

drv_priv(9F)

drv_usectohz(9F)

drv_usecwait(9F)

dupb(9F)

dupmsg(9F)

enableok(9F)

esballoc(9F)

esbbcall(9F)

flushband(9F)

flushq(9F)

freeb(9F)

freemsg(9F)

free_pktiopb(9F)

freerbuf(9F)

freezestr(9F)

geterror(9F)

gethrtime(9F)

getmajor(9F)

getminor(9F)

get_pktiopb(9F)

getq(9F)

getrbuf(9F)

gld(9F)

gld_intr(9F)

gld_mac_alloc(9F)

gld_mac_free(9F)

gld_recv(9F)

gld_register(9F)

gld_sched(9F)

gld_unregister(9F)

hat_getkpfnum(9F)

hook_alloc(9F)

hook_free(9F)

id32_alloc(9F)

id32_free(9F)

id32_lookup(9F)

inb(9F)

inl(9F)

insq(9F)

inw(9F)

IOC_CONVERT_FROM(9F)

kmem_alloc(9F)

kmem_cache_alloc(9F)

kmem_cache_create(9F)

kmem_cache_destroy(9F)

kmem_cache_free(9F)

kmem_free(9F)

kmem_zalloc(9F)

kstat_create(9F)

kstat_delete(9F)

kstat_install(9F)

kstat_named_init(9F)

kstat_named_setstr(9F)

kstat_queue(9F)

kstat_runq_back_to_waitq(9F)

kstat_runq_enter(9F)

kstat_runq_exit(9F)

kstat_waitq_enter(9F)

kstat_waitq_exit(9F)

kstat_waitq_to_runq(9F)

ldi_add_event_handler(9F)

ldi_aread(9F)

ldi_awrite(9F)

ldi_close(9F)

ldi_devmap(9F)

ldi_dump(9F)

ldi_get_dev(9F)

ldi_get_devid(9F)

ldi_get_eventcookie(9F)

ldi_get_minor_name(9F)

ldi_getmsg(9F)

ldi_get_otyp(9F)

ldi_get_size(9F)

ldi_ident_from_dev(9F)

ldi_ident_from_dip(9F)

ldi_ident_from_stream(9F)

ldi_ident_release(9F)

ldi_ioctl(9F)

ldi_open_by_dev(9F)

ldi_open_by_devid(9F)

ldi_open_by_name(9F)

ldi_poll(9F)

ldi_prop_exists(9F)

ldi_prop_get_int64(9F)

ldi_prop_get_int(9F)

ldi_prop_lookup_byte_array(9F)

ldi_prop_lookup_int64_array(9F)

ldi_prop_lookup_int_array(9F)

ldi_prop_lookup_string(9F)

ldi_prop_lookup_string_array(9F)

ldi_putmsg(9F)

ldi_read(9F)

ldi_remove_event_handler(9F)

ldi_strategy(9F)

ldi_write(9F)

linkb(9F)

mac(9F)

mac_alloc(9F)

mac_fini_ops(9F)

mac_free(9F)

mac_hcksum_get(9F)

mac_hcksum_set(9F)

mac_init_ops(9F)

mac_link_update(9F)

mac_lso_get(9F)

mac_prop_info_set_default_link_flowctrl(9F)

mac_prop_info_set_default_str(9F)

mac_prop_info_set_default_uint8(9F)

mac_prop_info_set_perm(9F)

mac_prop_info_set_range_uint32(9F)

mac_register(9F)

mac_rx(9F)

mac_tx_update(9F)

mac_unregister(9F)

makecom(9F)

makecom_g0(9F)

makecom_g0_s(9F)

makecom_g1(9F)

makecom_g5(9F)

makedevice(9F)

max(9F)

MBLKHEAD(9F)

MBLKIN(9F)

MBLKL(9F)

MBLKSIZE(9F)

MBLKTAIL(9F)

mcopyin(9F)

mcopymsg(9F)

mcopyout(9F)

membar_consumer(9F)

membar_enter(9F)

membar_exit(9F)

membar_ops(9F)

membar_producer(9F)

memchr(9F)

memcmp(9F)

memcpy(9F)

memmove(9F)

memset(9F)

merror(9F)

mexchange(9F)

min(9F)

minphys(9F)

mioc2ack(9F)

miocack(9F)

miocnak(9F)

miocpullup(9F)

mkiocb(9F)

mod_info(9F)

mod_install(9F)

mod_remove(9F)

msgdsize(9F)

msgpullup(9F)

msgsize(9F)

mt-streams(9F)

mutex(9F)

mutex_destroy(9F)

mutex_enter(9F)

mutex_exit(9F)

mutex_init(9F)

mutex_owned(9F)

mutex_tryenter(9F)

net_event_notify_register(9F)

net_event_notify_unregister(9F)

net_getifname(9F)

net_getlifaddr(9F)

net_getmtu(9F)

net_getnetid(9F)

net_getpmtuenabled(9F)

net_hook_register(9F)

net_hook_unregister(9F)

netinfo(9F)

net_inject(9F)

net_inject_alloc(9F)

net_inject_free(9F)

net_instance_alloc(9F)

net_instance_free(9F)

net_instance_notify_register(9F)

net_instance_notify_unregister(9F)

net_instance_protocol_unregister(9F)

net_instance_register(9F)

net_instance_unregister(9F)

net_ispartialchecksum(9F)

net_isvalidchecksum(9F)

net_kstat_create(9F)

net_kstat_delete(9F)

net_lifgetnext(9F)

net_netidtozonid(9F)

net_phygetnext(9F)

net_phylookup(9F)

net_protocol_lookup(9F)

net_protocol_notify_register(9F)

net_protocol_release(9F)

net_protocol_walk(9F)

net_routeto(9F)

net_zoneidtonetid(9F)

nochpoll(9F)

nodev(9F)

noenable(9F)

nulldev(9F)

numtos(9F)

nv_alloc_fini(9F)

nv_alloc_init(9F)

nvlist_add_boolean(9F)

nvlist_add_boolean_array(9F)

nvlist_add_boolean_value(9F)

nvlist_add_byte(9F)

nvlist_add_byte_array(9F)

nvlist_add_int16(9F)

nvlist_add_int16_array(9F)

nvlist_add_int32(9F)

nvlist_add_int32_array(9F)

nvlist_add_int64(9F)

nvlist_add_int64_array(9F)

nvlist_add_int8(9F)

nvlist_add_int8_array(9F)

nvlist_add_nvlist(9F)

nvlist_add_nvlist_array(9F)

nvlist_add_nvpair(9F)

nvlist_add_string(9F)

nvlist_add_string_array(9F)

nvlist_add_uint16(9F)

nvlist_add_uint16_array(9F)

nvlist_add_uint32(9F)

nvlist_add_uint32_array(9F)

nvlist_add_uint64(9F)

nvlist_add_uint64_array(9F)

nvlist_add_uint8(9F)

nvlist_add_uint8_array(9F)

nvlist_alloc(9F)

nvlist_dup(9F)

nvlist_free(9F)

nvlist_lookup_boolean(9F)

nvlist_lookup_boolean_array(9F)

nvlist_lookup_boolean_value(9F)

nvlist_lookup_byte(9F)

nvlist_lookup_byte_array(9F)

nvlist_lookup_int16(9F)

nvlist_lookup_int16_array(9F)

nvlist_lookup_int32(9F)

nvlist_lookup_int32_array(9F)

nvlist_lookup_int64(9F)

nvlist_lookup_int64_array(9F)

nvlist_lookup_int8(9F)

nvlist_lookup_int8_array(9F)

nvlist_lookup_nvlist(9F)

nvlist_lookup_nvlist_array(9F)

nvlist_lookup_pairs(9F)

nvlist_lookup_string(9F)

nvlist_lookup_string_array(9F)

nvlist_lookup_uint16(9F)

nvlist_lookup_uint16_array(9F)

nvlist_lookup_uint32(9F)

nvlist_lookup_uint32_array(9F)

nvlist_lookup_uint64(9F)

nvlist_lookup_uint64_array(9F)

nvlist_lookup_uint8(9F)

nvlist_lookup_uint8_array(9F)

nvlist_merge(9F)

nvlist_next_nvpair(9F)

nvlist_pack(9F)

nvlist_remove(9F)

nvlist_remove_all(9F)

nvlist_size(9F)

nvlist_t(9F)

nvlist_unpack(9F)

nvlist_xalloc(9F)

nvlist_xdup(9F)

nvlist_xpack(9F)

nvlist_xunpack(9F)

nvpair_name(9F)

nvpair_type(9F)

nvpair_value_boolean_array(9F)

nvpair_value_byte(9F)

nvpair_value_byte_array(9F)

nvpair_value_int16(9F)

nvpair_value_int16_array(9F)

nvpair_value_int32(9F)

nvpair_value_int32_array(9F)

nvpair_value_int64(9F)

nvpair_value_int64_array(9F)

nvpair_value_int8(9F)

nvpair_value_int8_array(9F)

nvpair_value_nvlist(9F)

nvpair_value_nvlist_array(9F)

nvpair_value_string(9F)

nvpair_value_string_array(9F)

nvpair_value_uint16(9F)

nvpair_value_uint16_array(9F)

nvpair_value_uint32(9F)

nvpair_value_uint32_array(9F)

nvpair_value_uint64(9F)

nvpair_value_uint64_array(9F)

nvpair_value_uint8(9F)

nvpair_value_uint8_array(9F)

OTHERQ(9F)

otherq(9F)

outb(9F)

outl(9F)

outw(9F)

pci_config_get16(9F)

pci_config_get32(9F)

pci_config_get64(9F)

pci_config_get8(9F)

pci_config_getb(9F)

pci_config_getl(9F)

pci_config_getll(9F)

pci_config_getw(9F)

pci_config_put16(9F)

pci_config_put32(9F)

pci_config_put64(9F)

pci_config_put8(9F)

pci_config_putb(9F)

pci_config_putl(9F)

pci_config_putll(9F)

pci_config_putw(9F)

pci_config_setup(9F)

pci_config_teardown(9F)

pci_ereport_post(9F)

pci_ereport_setup(9F)

pci_ereport_teardown(9F)

pci_report_pmcap(9F)

pci_restore_config_regs(9F)

pci_save_config_regs(9F)

physio(9F)

pm_busy_component(9F)

pm_idle_component(9F)

pm_lower_power(9F)

pm_power_has_changed(9F)

pm_raise_power(9F)

pm_trans_check(9F)

pollwakeup(9F)

priv_getbyname(9F)

priv_policy(9F)

priv_policy_choice(9F)

priv_policy_only(9F)

proc_ref(9F)

proc_signal(9F)

proc_unref(9F)

ptob(9F)

pullupmsg(9F)

put(9F)

putbq(9F)

putctl1(9F)

putctl(9F)

putnext(9F)

putnextctl1(9F)

putnextctl(9F)

putq(9F)

qassociate(9F)

qbufcall(9F)

qenable(9F)

qprocsoff(9F)

qprocson(9F)

qreply(9F)

qsize(9F)

qtimeout(9F)

qunbufcall(9F)

quntimeout(9F)

qwait(9F)

qwait_sig(9F)

qwriter(9F)

RD(9F)

rd(9F)

repinsb(9F)

repinsd(9F)

repinsw(9F)

repoutsb(9F)

repoutsd(9F)

repoutsw(9F)

rmalloc(9F)

rmallocmap(9F)

rmallocmap_wait(9F)

rmalloc_wait(9F)

rmfree(9F)

rmfreemap(9F)

rmvb(9F)

rmvq(9F)

rw_destroy(9F)

rw_downgrade(9F)

rw_enter(9F)

rw_exit(9F)

rw_init(9F)

rwlock(9F)

rw_read_locked(9F)

rw_tryenter(9F)

rw_tryupgrade(9F)

SAMESTR(9F)

samestr(9F)

scsi_abort(9F)

scsi_alloc_consistent_buf(9F)

scsi_cname(9F)

scsi_destroy_pkt(9F)

scsi_dmafree(9F)

scsi_dmaget(9F)

scsi_dname(9F)

scsi_errmsg(9F)

scsi_ext_sense_fields(9F)

scsi_find_sense_descr(9F)

scsi_free_consistent_buf(9F)

scsi_get_device_type_scsi_options(9F)

scsi_hba_attach(9F)

scsi_hba_attach_setup(9F)

scsi_hba_detach(9F)

scsi_hba_fini(9F)

scsi_hba_init(9F)

scsi_hba_lookup_capstr(9F)

scsi_hba_pkt_alloc(9F)

scsi_hba_pkt_comp(9F)

scsi_hba_pkt_free(9F)

scsi_hba_probe(9F)

scsi_hba_tran_alloc(9F)

scsi_hba_tran_free(9F)

scsi_ifgetcap(9F)

scsi_ifsetcap(9F)

scsi_init_pkt(9F)

scsi_log(9F)

scsi_mname(9F)

scsi_pktalloc(9F)

scsi_pktfree(9F)

scsi_poll(9F)

scsi_probe(9F)

scsi_resalloc(9F)

scsi_reset(9F)

scsi_reset_notify(9F)

scsi_resfree(9F)

scsi_rname(9F)

scsi_sense_asc(9F)

scsi_sense_ascq(9F)

scsi_sense_cmdspecific_uint64(9F)

scsi_sense_info_uint64(9F)

scsi_sense_key(9F)

scsi_setup_cdb(9F)

scsi_slave(9F)

scsi_sname(9F)

scsi_sync_pkt(9F)

scsi_transport(9F)

scsi_unprobe(9F)

scsi_unslave(9F)

scsi_validate_sense(9F)

scsi_vu_errmsg(9F)

sema_destroy(9F)

sema_init(9F)

sema_p(9F)

semaphore(9F)

sema_p_sig(9F)

sema_tryp(9F)

sema_v(9F)

SIZEOF_PTR(9F)

SIZEOF_STRUCT(9F)

snprintf(9F)

sprintf(9F)

stoi(9F)

strcasecmp(9F)

strchr(9F)

strcmp(9F)

strcpy(9F)

strlcat(9F)

strlcpy(9F)

strlen(9F)

strlog(9F)

strncasecmp(9F)

strncat(9F)

strncmp(9F)

strncpy(9F)

strqget(9F)

strqset(9F)

strrchr(9F)

strspn(9F)

STRUCT_BUF(9F)

STRUCT_DECL(9F)

STRUCT_FADDR(9F)

STRUCT_FGET(9F)

STRUCT_FGETP(9F)

STRUCT_FSET(9F)

STRUCT_FSETP(9F)

STRUCT_HANDLE(9F)

STRUCT_INIT(9F)

STRUCT_SET_HANDLE(9F)

STRUCT_SIZE(9F)

swab(9F)

taskq(9F)

taskq_suspended(9F)

testb(9F)

timeout(9F)

u8_strcmp(9F)

u8_textprep_str(9F)

u8_validate(9F)

uconv_u16tou32(9F)

uconv_u16tou8(9F)

uconv_u32tou16(9F)

uconv_u32tou8(9F)

uconv_u8tou16(9F)

uconv_u8tou32(9F)

uiomove(9F)

unbufcall(9F)

unfreezestr(9F)

unlinkb(9F)

untimeout(9F)

ureadc(9F)

usb_alloc_bulk_req(9F)

usb_alloc_ctrl_req(9F)

usb_alloc_intr_req(9F)

usb_alloc_isoc_req(9F)

usb_alloc_request(9F)

usb_client_attach(9F)

usb_client_detach(9F)

usb_clr_feature(9F)

usb_create_pm_components(9F)

usb_free_bulk_req(9F)

usb_free_ctrl_req(9F)

usb_free_descr_tree(9F)

usb_free_dev_data(9F)

usb_free_intr_req(9F)

usb_free_isoc_req(9F)

usb_get_addr(9F)

usb_get_alt_if(9F)

usb_get_cfg(9F)

usb_get_current_frame_number(9F)

usb_get_dev_data(9F)

usb_get_if_number(9F)

usb_get_max_pkts_per_isoc_request(9F)

usb_get_status(9F)

usb_get_string_descr(9F)

usb_handle_remote_wakeup(9F)

usb_lookup_ep_data(9F)

usb_owns_device(9F)

usb_parse_data(9F)

usb_pipe_bulk_xfer(9F)

usb_pipe_close(9F)

usb_pipe_ctrl_xfer(9F)

usb_pipe_ctrl_xfer_wait(9F)

usb_pipe_drain_reqs(9F)

usb_pipe_get_max_bulk_transfer_size(9F)

usb_pipe_get_private(9F)

usb_pipe_get_state(9F)

usb_pipe_intr_xfer(9F)

usb_pipe_isoc_xfer(9F)

usb_pipe_open(9F)

usb_pipe_reset(9F)

usb_pipe_set_private(9F)

usb_pipe_stop_intr_polling(9F)

usb_pipe_stop_isoc_polling(9F)

usb_print_descr_tree(9F)

usb_register_hotplug_cbs(9F)

usb_set_alt_if(9F)

usb_set_cfg(9F)

usb_unregister_hotplug_cbs(9F)

uwritec(9F)

va_arg(9F)

va_copy(9F)

va_end(9F)

va_start(9F)

vcmn_err(9F)

vsprintf(9F)

WR(9F)

wr(9F)

zcmn_err(9F)

ddi_intr_add_softint

, ddi_intr_remove_softint

, ddi_intr_trigger_softint

, ddi_intr_get_softint_pri

, ddi_intr_set_softint_pri

- software interrupt handling routines

Synopsis

#include <sys/types.h>
#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>



int ddi_intr_add_softint(dev_info_t *dip, 
     ddi_softint_handle_t *h, int soft_pri, 
     ddi_intr_handler_t handler, void *arg1);
int ddi_intr_trigger_softint(ddi_softint_handle_t h,
      void *arg2);
int ddi_intr_remove_softint(ddi_softint_handle_t h);
int ddi_intr_get_softint_pri(ddi_softint_handle_t h,
      uint *soft_prip);
int ddi_intr_set_softint_pri(ddi_softint_handle_t h,
      uint soft_pri);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

ddi_intr_add_softint()

dip

Pointer to a dev_info structure

h

Pointer to the DDI soft interrupt handle

soft_pri

Priority to associate with a soft interrupt

handler

Pointer to soft interrupt handler

arg1

Argument for the soft interrupt handler

ddi_intr_trigger_softint()

h

DDI soft interrupt handle

arg2

Additional argument for the soft interrupt handler

ddi_intr_remove_softint()

h

DDI soft interrupt handle

ddi_intr_get_softint_pri()

h

DDI soft interrupt handle

soft_prip

Soft interrupt priority of the handle

ddi_intr_set_softint_pri()

h

DDI soft interrupt handle

soft_prip

Soft interrupt priority of the handle

Description

The ddi_intr_add_softint() function adds the soft interrupt handler given by the handler argument arg1. The handler runs at the soft interrupt priority given by the soft_pri argument.

The value returned in the location pointed at by h is the soft interrupt handle. This value is used in later calls to ddi_intr_remove_softint(), ddi_intr_trigger_softint() and ddi_intr_set_softint_pri().

The software priority argument soft_pri is a relative priority value within the range of DDI_INTR_SOFTPRI_MIN and DDI_INTR_SOFTPRI_MAX. If the driver does not know what priority to use, the default soft_pri value of DDI_INTR_SOFTPRI_DEFAULT could be specified. The default value is the lowest possible soft interrupt priority value.

The soft_pri argument contains the value needed to initialize the lock associated with a soft interrupt. See mutex_init(9F) and rw_init(9F). The handler cannot be triggered until the lock is initiatized.

The ddi_intr_remove_softint() function removes the handler for the soft interrupt identified by the interrupt handle h argument. Once removed, the soft interrupt can no longer be triggered, although any trigger calls in progress can still be delivered to the handler.

Drivers must remove any soft interrupt handlers before allowing the system to unload the driver. Otherwise, kernel resource leaks might occur.

The ddi_intr_trigger_softint() function triggers the soft interrupt specified by the interrupt handler h argument. A driver may optionally specify an additional argument arg2 that is passed to the soft interrupt handler. Subsequent ddi_intr_trigger_softint() events, along with arg2, will be dropped until the one pending is serviced and returns the error code DDI_EPENDING.

The routine handler, with the arg1 and arg2 arguments, is called upon the receipt of a software interrupt. These were registered through a prior call to ddi_intr_add_softint(). Software interrupt handlers must not assume that they have work to do when they run. Like hardware interrupt handlers, they may run because a soft interrupt has occurred for some other reason. For example, another driver may have triggered a soft interrupt at the same level. Before triggering the soft interrupt, the driver must indicate to the soft interrupt handler that it has work to do. This is usually done by setting a flag in the state structure. The routine handler checks this flag, reached through arg1 and arg2, to determine if it should claim the interrupt and do its work.

The interrupt handler must return DDI_INTR_CLAIMED if the interrupt was claimed and DDI_INTR_UNCLAIMED otherwise.

The ddi_intr_get_softint_pri() function retrieves the soft interrupt priority, a small integer value, associated with the soft interrupt handle. The handle is defined by the h argument, and the priority returned is in the value of the integer pointed to by the soft_prip argument.

Return Values

The ddi_intr_add_softint(), ddi_intr_remove_softint(), ddi_intr_trigger_softint(), ddi_intr_get_softint_pri(), ddi_intr_set_softint_pri() functions return:

DDI_SUCCESS

On success.

DDI_EAGAIN

On encountering internal error regarding currently unavailable resources.

DDI_EINVAL

On encountering invalid input parameters.

DDI_FAILURE

On any implementation specific failure.

DDI_EPENDING

On encountering a previously triggered softint event that is pending.

Context

The ddi_intr_add_softint(), ddi_intr_remove_softint(), ddi_intr_trigger_softint(), ddi_intr_get_softint_pri(), ddi_intr_set_softint_pri() functions can be called from either user or kernel non-interrupt context.

Examples

Example 1 Device using high-level interrupts

In the following example, the device uses high-level interrupts. High-level interrupts are those that interrupt at the level of the scheduler and above. High-level interrupts must be handled without using system services that manipulate thread or process states, because these interrupts are not blocked by the scheduler. In addition, high-level interrupt handlers must take care to do a minimum of work because they are not preemptable. See ddi_intr_get_hilevel_pri(9F).

In the example, the high-level interrupt routine minimally services the device, and enqueues the data for later processing by the soft interrupt handler. If the soft interrupt handler is not currently running, the high-level interrupt routine triggers a soft interrupt so the soft interrupt handler can process the data. Once running, the soft interrupt handler processes all the enqueued data before returning.

The state structure contains two mutexes. The high-level mutex is used to protect data shared between the high-level interrupt handler and the soft interrupt handler. The low-level mutex is used to protect the rest of the driver from the soft interrupt handler.

struct xxstate {
  ...
  ddi_intr_handle_t       int_hdl;
  int                     high_pri;
  kmutex_t                high_mutex;
  ddi_softint_handle_t    soft_hdl;
  int                     low_soft_pri;
  kmutex_t                low_mutex;
  int                     softint_running;
  ...
};

struct xxstate *xsp;
static uint_t xxsoftint_handler(void *, void *);
static uint_t xxhighintr(void *, void *);
...

Example 2 Sample attach() routine

The following code fragment would usually appear in the driver's attach(9E) routine. ddi_intr_add_handler(9F) is used to add the high-level interrupt handler and ddi_intr_add_softint() is used to add the low-level interrupt routine.

static uint_t
xxattach(dev_info_t *dip, ddi_attach_cmd_t cmd)
{
   int             types;
   int             *actual;
   int             nintrs;
   struct xxstate  *xsp;
   ...

   (void) ddi_intr_get_supported_types(dip, &types);
   (void) ddi_intr_get_nintrs(dip< DDI_INTR_TYPE_FIXED, *nintrs);
   (void) ddi_intr_alloc(dip, &xsp->int_hdl, DDI_INTR_TYPE_FIXED,
       1, nintrs, *actual, 0);

   /* initialize high-level mutex */
   (void) ddi_intr_get_pri(xsp->int_hdl, &>high_pri);
   mutex_init(&xsp->high_mutex, NULL, MUTEX_DRIVER,
       DDI_INTR_PRI(xsp->high_pri));

   /* Ensure that this is a hi-level interrupt */
   if (ddi_intr_get_hilevel_pri(h) != DDI_SUCCESS) {
           /* cleanup */
           return (DDI_FAILURE); /* fail attach */
   }

   /* add high-level routine - xxhighintr() */
   if (ddi_intr_add_handler(xsp->int_hdl, xxhighintr,
       arg1, NULL) != DDI_SUCCESS) {
           /* cleanup */
           return (DDI_FAILURE); /* fail attach */
   }

   /* Enable high-level routine - xxhighintr() */
   if (ddi_intr_enable(xsp->int_hdl) != DDI_SUCCESS) {
           /* cleanup */
           return (DDI_FAILURE); /* fail attach */
   }

   /* Enable soft interrupts */
   xsp->low_soft_pri = DDI_INTR_SOFTPRI_MIN;
   if (ddi_intr_add_softint(dip, &xsp>soft_hdl,
       xsp->low_soft_pri, xxsoftint_handler, arg1) != DDI_SUCCESS) {
           /* clean up */
           return (DDI_FAILURE); /* fail attach */
   }

   /* initialize low-level mutex */
   mutex_init(&xsp->low_mutex, NULL, MUTEX_DRIVER,
       DDI_INTR_PRI(xsp->low_soft_pri));

   ...
}

Example 3 High-level interrupt routine

The next code fragment represents the high-level interrupt routine. The high-level interrupt routine minimally services the device and enqueues the data for later processing by the soft interrupt routine. If the soft interrupt routine is not already running, ddi_intr_trigger_softint() is called to start the routine. The soft interrupt routine will run until there is no more data on the queue.

static uint_t
xxhighintr(void *arg1, void *arg2)
{
   struct xxstate *xsp = (struct xxstate *)arg1;
   int need_softint;
   ...
   mutex_enter(&xsp->high_mutex);
   /*
   * Verify this device generated the interrupt
   * and disable the device interrupt.
   * Enqueue data for xxsoftint_handler() processing.
   */

   /* is xxsoftint_handler() already running ? */
   need_softint = (xsp->softint_running) ? 0 : 1;
   mutex_exit(&xsp->high_mutex);

   /* read-only access to xsp->id, no mutex needed */
   if (xsp->soft_hdl && need_softint)
           ddi_intr_trigger_softint(xsp->soft_hdl, arg2);
   ...
   return (DDI_INTR_CLAIMED);
}


static uint_t
xxsoftint_handler(void *arg1, void *arg2)
{
   struct xxstate *xsp = (struct xxstate *)arg1;
   ...
   mutex_enter(&xsp->low_mutex);
   mutex_enter(&xsp->high_mutex);

   /* verify there is work to do */
   if (work queue empty || xsp->softint_running )  {
           mutex_exit(&xsp->high_mutex);
           mutex_exit(&xsp->low_mutex);
           return (DDI_INTR_UNCLAIMED);
   }

   xsp->softint_running = 1;

   while ( data on queue )  {
           ASSERT(mutex_owned(&xsp->high_mutex));
           /* de-queue data */
           mutex_exit(&xsp->high_mutex);

           /* Process data on queue */
           mutex_enter(&xsp->high_mutex);
   }

   xsp->softint_running = 0;
   mutex_exit(&xsp->high_mutex);
   mutex_exit(&xsp->low_mutex);
   return (DDI_INTR_CLAIMED);
}

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(5), attach(9E), ddi_intr_alloc(9F), ddi_intr_free(9F), ddi_intr_get_hilevel_pri(9F), mutex_init(9F), rw_init(9F), rwlock(9F)

Writing Device Drivers

Notes

Consumers of these interfaces should verify that the return value is not equal to DDI_SUCCESS. Incomplete checking for failure codes could result in inconsistent behavior among platforms.

The ddi_intr_add_softint() may not be used to add the same software interrupt handler more than once. This is true even if a different value is used for arg1 in each of the calls to ddi_intr_add_softint(). Instead, the argument passed to the interrupt handler should indicate what service(s) the interrupt handler should perform. For example, the argument could be a pointer to the soft state structure of the device that could contain a which_service field that the handler examines. The driver must set this field to the appropriate value before calling ddi_intr_trigger_softint().

Every time a modifiable valid second argument, arg2, is provided when ddi_intr_trigger_softint() is invoked, the DDI framework saves arg2 internally and passes it to the interrupt handler handler.

A call to ddi_intr_set_softint_pri() could fail if a previously scheduled soft interrupt trigger is still pending.