|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- Issue a dump request to a device
#include <sys/sunldi.h> int ldi_dump(ldi_handle_t lh, caddr_t addr, daddr_t blkno, int nblk);
Area dump address.
Block offset to dump memory.
Number of blocks to dump.
The ldi_dump() function passes a dump request to the device entry point specified by the layered handle. This operation is supported for block devices.
The ldi_dump() function returns 0 upon success. If a failure occurs before the request is passed on to the device, the possible return values are shown below. Otherwise any other error number may be returned by the device.
Invalid input parameters.
Operation is not supported for this device.
These functions may be called from user or kernel context.