|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- convert a DMA handle to a DMA address cookie
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_htoc(ddi_dma_handle_t handle, off_t off, ddi_dma_cookie_t *cookiep);
The handle filled in by a call to ddi_dma_setup(9F).
An offset into the object that handle maps.
A pointer to a ddi_dma_cookie(9S) structure.
The ddi_dma_htoc() function takes a DMA handle (established by ddi_dma_setup(9F)), and fills in the cookie pointed to by cookiep with the appropriate address, length, and bus type to be used to program the DMA engine.
The ddi_dma_htoc() function returns:
Successfully filled in the cookie pointed to by cookiep.
Failed to successfully fill in the cookie.
The ddi_dma_htoc() function can be called from user, interrupt, or kernel context.
See attributes(5) for a description of the following attributes: