|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- disable a hook that was called in event processing
#include <sys/neti.h> int net_hook_unregister(const net_data_t net, nethook_t hook);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_register().
value returned from a successful call to net_hook_register(9F).
The net_hook_unregister() function disables the callback hooks that were registered with the net_hook_register() function.
If the net_hook_unregister() function succeeds, 0 is returned. Otherwise, an error indicating the problem encountered.
The net_hook_unregister() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: