|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- call a function when a buffer becomes available
#include <sys/stream.h> #include <sys/ddi.h> bufcall_id_t qbufcall(queue_t *q, size_t size, uint_t pri, void(*func)(void *arg), void *arg);
Solaris DDI specific (Solaris DDI).
Pointer to STREAMS queue structure.
Number of bytes required for the buffer.
Priority of the allocb(9F) allocation request (not used).
Function or driver routine to be called when a buffer becomes available.
Argument to the function to be called when a buffer becomes available.
The qbufcall() function serves as a qtimeout(9F) call of indeterminate length. When a buffer allocation request fails, qbufcall() can be used to schedule the routine func to be called with the argument arg when a buffer becomes available. func may call allocb() or it may do something else.
The qbufcall() function is tailored to be used with the enhanced STREAMS framework interface, which is based on the concept of perimeters. (See mt-streams(9F).) qbufcall() schedules the specified function to execute after entering the perimeters associated with the queue passed in as the first parameter to qbufcall(). All outstanding timeouts and bufcalls must be cancelled (using, respectively, quntimeout(9F) and qunbufcall(9F)) before a driver close routine can block and before the close routine calls qprocsoff(9F).
If successful, the qbufcall() function returns a qbufcall ID that can be used in a call to qunbufcall(9F) to cancel the request. If the qbufcall() scheduling fails, func is never called and 0 is returned.
The qbufcall() function can be called from user, interrupt, or kernel context.