|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 10 8/11 Information Library|
- cancel a pending bufcall request
#include <sys/stream.h> void unbufcall(bufcall_id_t id);
Architecture independent level 1 (DDI/DKI).
The unbufcall function cancels a pending bufcall() or esbbcall() request. The argument id is a non-zero identifier for the request to be cancelled. id is returned from the bufcall() or esbbcall() function used to issue the request. unbufcall() will not return until the pending callback is cancelled or has run. Because of this, locks acquired by the callback routine should not be held across the call to unbufcall() or deadlock may result.
The unbufcall function can be called from user, interrupt, or kernel context.