|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- display kernel audit statistics
auditstat [-c count] [-h numlines] [-i interval] [-n] [-T u | d ] [-v]
auditstat displays kernel audit statistics. The fields displayed are as follows:
The total number of audit records processed by the userland audit.
This field is obsolete.
The total number of audit records that have been dropped. Records are dropped according to the kernel audit policy. See auditconfig(1M), AUDIT_CNT policy for details.
The total number of audit records put on the kernel audit queue.
The total number of audit records that have been constructed (not the number written).
The total number of audit records produced by user processes (as a result of system calls).
The total number of Kbytes of memory currently in use by the kernel audit module.
The total number of non-attributable audit records that have been constructed. These are audit records that are not attributable to any particular user.
The total number of times that the audit queue has blocked waiting to process audit data.
The total number of Kbytes of audit data written to the audit trail.
The total number of times that user processes blocked on the audit queue at the high water mark.
The total number of audit records written. The difference between enq and wrtn is the number of outstanding audit records on the audit queue that have not been written.
Display the statistics a total of count times. If count is equal to zero, statistics are displayed indefinitely. A time interval must be specified.
Display a header for every numlines of statistics printed. The default is to display the header every 20 lines. If numlines is equal to zero, the header is never displayed.
Display the statistics every interval where interval is the number of seconds to sleep between each collection.
Display the number of kernel audit events currently configured.
Display a time stamp.
Display the version number of the kernel audit module software.
auditstat returns 0 upon success and 1 upon failure.
See attributes(5) for descriptions of the following attributes:
See the section on Auditing in Oracle Solaris 11.1 Administration: Security Services.