|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- administer interfaces in an IP multipathing group
if_mpadm -d | -r ifname
The if_mpadm utility administers IP interfaces that are part of an IP Multipathing (IPMP) group. Currently, administration is limited to offlining IP interfaces and undoing previous offline operations.
When an IP interface is taken offline, all IP data traffic that was flowing over the IP interface is moved to another IP interface in the IPMP group. In addition, all UP IP addresses hosted on the IP interface are brought down, causing in.mpathd(1M) to stop probe-based failure detection on the IP interface. As a result, an offline IP interface will not be used for any inbound or outbound IP traffic. Only IP interfaces that are in an IPMP group may be brought offline. If the IP interface is the last functioning interface in the IPMP group, the offline operation will fail.
When an offline operation is undone, any IP addresses hosted on that IP interface are brought UP and will be considered by in.mpathd for probe-based failure detection. In addition, provided the IP interface is otherwise active (see in.mpathd(1M)), it will again be used to send and receive IP data traffic for the IPMP group. Note that not all offline operations can be undone. For instance, in.mpathd may have offlined an IP interface because its hardware address was not unique within its IPMP group. The ipmpstat utility can be used to determine why an IP interface is offline, identify which IP interfaces in a group are being used for inbound and outbound IP traffic, and more; see ipmpstat(1M).
The if_mpadm utility supports the following options:
Offline the IP interface specified by ifname. If ifname is not in an IPMP group, or the offline would cause the IPMP group to lose network connectivity, the operation will fail.
Undo a previous offline of the IP interface specified by ifname. If ifname is not offline, the operation will fail.
Example 1 Offlining an IP Interface
The following command offlines the IP interface under0, causing any IP packets that were being sent and received through it to be handled by another IP interface in its group.
example% if_mpadm -d under0
Example 2 Undoing a Previous Offline Operation
Use the following command to undo the operation in the previous example:
example% if_mpdadm -r under0
See attributes(5) for descriptions of the following attributes:
cannot offline: no other functioning interfaces are in its IPMP group.
Description: This message means that offlining the IP interface would leave the IPMP group without network connectivity.
cannot offline: not a physical interface or not in an IPMP group
Description: This means that the IP interface is not an underlying interface in an IPMP group, and therefore is not eligible to be offlined.