|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- administer the Solaris I/O remapping feature
/usr/platform/sun4v/sbin/device_remap [-v | -R dir]
Certain multi-node sun4v platforms, such as T5440 and T5240 servers, have an integrated PCI topology that cause the I/O device paths to change in a CPU node failover condition. The device remapping script, device_remap, remaps the device paths in /etc/path_to_inst file and the symlinks under /dev to match the hardware.
The following options are supported:
Displays the /etc/path_to_inst and /dev symlink changes.
Perform remapping on the /etc/path_to_inst and /etc/path_to_inst files in the root image at dir.
The primary function of device_remap is to remap the device paths in the /etc/path_to_inst file and the symlinks under /dev in a CPU node failover condition to match the hardware.
After adding CPU node(s) or removing CPU node(s), boot the system to the OBP prompt and use the following procedure:
Boot either the failsafe miniroot using: boot -F failsafe , or an install miniroot using boot net -s or similar command.
Mount the root disk as /mnt.
Change directory to the mounted root disk:
# cd /mnt
Run device_remap script:
Boot the system from disk.
All the error messages are self-explanatory, except for the error message “missing ioaliases node” which means the firmware on the system does not support device remapping.
Example 1 Displaying Changes Following Failover
The following command displays the path_to_inst and /dev changes following a CPU node failover.
# device_remap -v
Example 2 Changing Directory Prior to Any Changes
The following command changes the directory on which the boot image is mounted prior to making any changes.
# device_remap -R /newroot
See attributes(5) for descriptions of the following attributes: