|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- list HAL devices
The lshal command displays items in the HAL device database.
When invoked without options, lshal defaults to long output (-l). Long output includes all devices and all properties associated with each device.
The -s option lists only UDIs (Unique Device Identifier) for all HAL devices.
The -t option prints the HAL device tree, reflecting parent-child relationships with whitespace indentation.
The -u option limits output to the specified device.
When invoked with -m option, lshal monitors HAL device changes, such as property modification and device addition and removal. This option can be combined with the -u option to monitor a particular device.
The following options are supported:
Show help information.
Monitor device list.
Short output (display only non-static part of UDI).
Show only the specified device.
Display version number.
See attributes(5) for descriptions of the following attributes: