|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures|
- device interrupt cookie
#include <sys/ddi.h> #include <sys/sunddi.h>
The ddi_idevice_cookie_t structure contains interrupt priority and interrupt vector information for a device. This structure is useful for devices having programmable bus-interrupt levels. ddi_add_intr(9F) assigns values to the ddi_idevice_cookie_t structure members.
u_short idev_vector; /* interrupt vector */ ushort_t idev_priority; /* interrupt priority */
The idev_vector field contains the interrupt vector number for vectored bus architectures such as VMEbus. The idev_priority field contains the bus interrupt priority level.
See attributes(5) for descriptions of the following attributes: