|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- AMD-8111 Fast Ethernet Network Adapter driver
The amd8111s Fast Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on the AMD-8111 Fast Ethernet Network Adapter.
The amd8111s driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.
The cloning, character-special device /dev/amd8111 is used to access all AMD-8111 Fast Ethernet devices installed within the system.
The amd8111s driver is managed by the dladm(1M) command line utility, which allows VLANs to be defined on top of amd8111s instances and for amd8111s instances to be aggregated. See dladm(1M) for more details.
By default, the amd8111s driver performs auto-negotiation to select the link speed and mode. Link speed and mode can be any of the following:
100 Mbps, full-duplex.
100 Mbps, half-duplex.
10 Mbps, full-duplex.
10 Mbps, half-duplex.
Special character device.
32-bit ELF kernel module (x86).
64-bit ELF Kernel module (x86).
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide