|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- provides disk and SCSI tape support for HP Smart Array controllers
The cpqary3 module provides low-level interface routines between the common disk I/O subsystem and the HP SMART Array controllers. The cpqary3 driver provides disk and SCSI tape support for the HP Smart Array controllers.
Please refer to the cpqary3 Release Notes, for the supported HP Smart Array Controllers and Storage boxes.
Each of the controller should be the sole initiator on a SCSI bus. Auto configuration code determines if the adapter is present at the Configured address and what types of devices are attached to it.
Use the Array Configuration Utility to configure the controllers. Each controller can support up to 32 logical volumes. In addition, each controller supports up to a maximum of 28 connected SCSI tape drives. With 1.90 and later versions of cpqary3 driver, HP Smart Array SAS controllers, having Firmware Revision 5.10 or later, support 64 logical drives. This firmware also supports Dual Domian Multipath configurations.
The driver attempts to initialize itself in accordance with the information found in the configuration file, /kernel/drv/cpqary3.conf.
The target driver's configuration file need entries if support is needed for targets numbering greater than the default number of targets supported by the corresponding target driver.
By default, entries for SCSI target numbers 0 to 15 are present in sd.conf. Entries for target numbers 16 and above are added in SCSI class in the sd.conf file for supporting corresponding logical volumes.
If SCSI tape drives are connected to the supported controllers, entries for target IDs from 33 to 33+n must be added in the /kernel/drv/st.conf file under scsi class, where n is the total number of SCSI tape drives connected to the controller with largest number of tape drives connected to it, in the existing configuration. For example, two supported controllers, c1 and c2 are present in the system. If controller c1 has two tape drives and controller c2 has five tape drives connected, entries for target IDs 33 through 38 are required under scsi class in /kernel/drv/st.conf file. The maximum number of tape drives that can be connected to a controller is 28. With 1.90 and later versions of the cpqary3 driver, if tape drives are connected to the Smart Array SAS controllers, target ID entries for tape drives from 65 to 65+n must be added in the /kernel/drv/st.conf file under the scsi class.
Configuration file for CPQary3
Configuration file for sd
Configuration file for st
Block special file names for disk device
Character special file names for disk device
Special file names for SCSI tape devices
cpqary3 Release Notes
The Smart Array controllers supported by the current version of the cpqary3 driver do not support format unit SCSI command. Therefore, selecting the format option under the format utility main menu is not supported. In addition, the repair option under format utility main menu is not supported as this operation is not applicable to Logical volumes connected to the supported Smart Array controllers.
The names of the block files can be found in /dev/dsk. The names of the raw files can be found in /dev/rdsk.