|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- universal disk format file system
The udfs file system is a file system type that allows user access to files on Universal Disk Format (UDF) disks from within the Solaris operating environment. Once mounted, a udfs file system provides standard Solaris file system operations and semantics. That is, users can read files, write files, and list files in a directory on a UDF device and applications can use standard UNIX system calls on these files and directories.
Because udfs is a platform-independent file system, the same media can be written to and read from by any operating system or vendor.
udfs file systems are mounted using:
mount-F udfs -o rw/ro device-special
if the /udfs and device special file /dev/dsk/c0t6d0s0 are valid and the following line (or similar line) appears in your /etc/vfstab file:
/dev/dsk/c0t6d0s0 - /udfs udfs - no ro
The udfs file system provides read-only support for ROM, RAM, and sequentially–recordable media and read-write support on RAM media.
The udfs file system also supports regular files, directories, and symbolic links, as well as device nodes such as block, character, FIFO, and Socket.
Invalid characters such as “NULL” and "/” and invalid file names such as "." and ".." will be translated according to the following rule:
Replace the invalid character with an “_," then append the file name with # followed by a 4 digit hex representation of the 16-bit CRC of the original FileIdentifier. For example, the file name ".." will become "__#4C05"