|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Realtek Gigabit/Fast Ethernet Network Adapter driver
The rge Gigabit/Fast Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on the Realtek Gigabit/Fast Ethernet Network Adapter.
The rge driver functions includes controller initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.
The cloning, character-special device /dev/rge is used to access all Realtek Gigabit/Fast Ethernet devices installed within the system.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ are as follows:
Maximum SDU (with jumbo frame) is 7000.
Minimum SDU is 0.
DSLAP address length is 8 bytes.
MAC type is DL_ETHER.
SAP length value is -2, meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.
Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular Service Access Point (SAP) with the stream.
By default, the rge driver performs auto-negotiation to select the link speed and mode. Link speed and mode can be any one of the following:
1000 Mbps, full-duplex
100 Mbps, full-duplex
100 Mbps, half-duplex
10 Mbps, full-duplex
10 Mbps, half-duplex
Alternatively, you can set the capabilities advertised by the rge device using ndd(1M). The driver supports a number of parameters whose names begin with adv_. Each of these parameters contains a boolean value that determines if the device advertises that mode of operation. The adv_pause_cap indicates if half/full duplex pause is advertised to link partner. You can set adv_asym_pause_cap to advertise to the link partner that asymmetric pause is desired.
For example, to prevent the device 'rge2' from advertising gigabit capabilities, enter (as super-user):
# ndd -set /dev/rge2 adv_1000fdx_cap 0
All capabilities default to enabled. Note that changing any capability parameter causes the link to go down while the link partners renegotiate the link speed/duplex using the newly changed capabilities.
You can find the current parameter settings by using ndd -get. In addition, the driver exports the current state, speed, duplex setting, and working mode of the link via ndd parameters (these are read only and may not be changed). For example, to check link state of device rge0:
# ndd -get /dev/rge0 link_status 1 # ndd -get /dev/rge0 link_speed 100 # ndd -get /dev/rge0 link_duplex 2
The output above indicates that the link is up and running at 100Mbps full-duplex. In addition, the driver exports its working mode by loop_mode. If it is set to 0, the loopback mode is disabled.
Character special device.
32–bit x86 rge driver binary.
64–bit x86 rge driver binary.
SPARC rge driver binary.
See attributes(5) for a description of the following attributes:
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide