|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Ultra-SPARC T2 random number generator device driver
The n2rng device driver is a multi-threaded, loadable hardware driver supporting hardware assisted random numbers. This support is built into the Ultra-SPARC T2 CMT processor.
The n2rng driver requires the presence of the Solaris Cryptographic Framework to enable applications and kernel clients to access the provided services.
You configure the n2rng driver by defining properties in /platform/sun4v/kernel/drv/n2cp.conf which override the default settings. The following property is supported:
Disables the generation of statistics. The nostats property may be used to help prevent traffic analysis, however, this may inhibit support personnel.
Status (online, offline, fail) of RNG device.
Number of requests for random data.
Number of bytes read from the RNG device.
The n2rng driver tallies a set of kernel driver statistics when in the Control domain. Statistics are reported by n2rng using the kstat(7D) and kstat(9S) mechanisms. All statistics are maintained as unsigned, and all are 64 bits.
Bias setting for noise cell 0 of RNG n.
Entropy value for noise cell 0 of RNG n.
Bias setting for noise cell 1 of RNG n.
Entropy value for noise cell 1 of RNG n.
Bias setting for noise cell 2 of RNG n.
Entropy value for noise cell 2 of RNG n.
State of rng number n (online, offline, error, health check).
64-bit ELF kernel driver.
See attributes(5) for descriptions of the following attributes:
Solaris Cryptographic Framework - Solaris Software Developer Collection
Solaris Security for Developer's Guide - Solaris Software Developer Collection