|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Emulex-Sun LightPulse Fibre Channel host bus adapter driver
The emlxs host bus adapter driver is a Sun Fibre Channel transport layer-compliant nexus driver for the Emulex Light-Pulse family of Fibre Channel adapters. These adapters support Fibre Channel SCSI and IP Protocols, FC-AL public loop profile, point-to-point fabric connection and Fibre Channel service classes two and three.
The emlxs driver interfaces with the Sun Fibre Channel transport layer to support the standard functions provided by the SCSA interface. It supports auto request sense and tagged queueing by default. The driver requires that all devices have unique hard addresses in private loop configurations. Devices with conflicting hard addresses are not accessible.
32–bit ELF kernel module.
64-bit ELF kernel module (x86).
64-bit ELF kernel module (SPARC).
Driver configuration file
See attributes(5) for descriptions of the following attributes:
prtconf(1M), driver.conf(4), fcp(7D), fp(7d)
Writing Device Drivers
ANSI X3.230:1994, Fibre Channel Physical Signaling (FC-PH)
Project 1134-D, Fibre Channel Generic Services (FC-GS-2)
ANSI X3.269-1996, Fibre Channel Arbitrated Loop (FC-AL)
ANSI X3.270-1996, Fibre Channel Protocol for SCSI (FCP-SCSI)
ANSI X3.270-1996, SCSI-3 Architecture Model (SAM)
Fibre Channel Private Loop SCSI Direct Attach (FC-PLDA)
Fabric Loop Attachment (FC-FLA)