|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- USB interface association driver
The usb_ia driver is a USBA (Solaris Universal Serial Bus Architecture)-compliant nexus driver that binds to a device's interface association nodes when no vendor or class specific driver is available. To do this, usb_ia creates nodes for the internal interfaces and then attempts to bind drivers to each child interface.
Each interface association node has a parent device node that is created by usb_mid(7D) and all ugen(7D) interfaces are exported by usb_mid(7D). (Note: attempting to export ugen(7D) interfaces using usb_ia is prohibited.)
32-bit ELF kernel module. (x86).
64-bit ELF kernel module. (x86).
64-bit ELF kernel module. (SPARC).
See attributes(5) for descriptions of the following attributes:
Universal Serial Bus Specification 2.0 — 2000
Interface Association Descriptor Engineering Change Notice (ECN)—2003
In addition to being logged, the following messages may appear on the system console. All messages are formatted in the following manner:
<device path> (usb_ia<instance num>):message...
No driver is available for this interface.