|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- GUI-based device driver utility
The GUI-based device driver utility, ddu, provides information about devices on a system running the Oracle Solaris operating system. ddu enables a user to connect to the Image Packaging System (IPS) and search device drivers for the devices that do not have drivers attached to them. By doing this, ddu gives the user an opportunity to install missing drivers.
ddu is a GUI, with an easy-to-use interface. It has a text-based counterpart, ddu-text(1M), which is described in its own man page.
The following options is supported:
ddu runs silently. If it finds devices that are missing drivers a notification is posted. Clicking on the notification displays the DDU GUI.
Example 1 Launching the ddu GUI
The following command launches the ddu GUI.
Example 2 Launching ddu in Silent Mode
The following command launches ddu in silent mode.
% ddu --silent
Application exited successfully.
Application exited with a failure.
Executable for ddu.
See attributes(5) for descriptions of the following attributes:
Additional availability attribute values are: diagnostic/ddu/data, diagnostic/ddu/library, and diagnostic/ddu/locale.