|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- convert an internal text label to its human readable equivalent
/usr/sbin/hextoalabel -c [internal-text-clearance]
hextoalabel converts an internal text label into its human readable equivalent and writes the result to the standard output file. This internal form is often hexadecimal. If no option is supplied, the label is assumed to be a sensitivity label.
If no internal text label is specified, the label is read from the standard input file. The expected use of this command is emergency repair of labels that are stored in internal databases.
Identifies the internal text label as a clearance.
The following exit values are returned:
On failure, and writes diagnostics to the standard error file.
See attributes(5) for descriptions of the following attributes:
The command output is Committed for systems with the same label_encodings file. The command invocation is Committed for systems that implement the DIA MAC policy.
The label encodings file contains the classification names, words, constraints, and values for the defined labels of this system.
The functionality described on this manual page is available only if the system is configured with Trusted Extensions.
This file is part of the Defense Intelligence Agency (DIA) Mandatory Access Control (MAC) policy. This file might not be applicable to other MAC policies that might be developed for future releases of Solaris Trusted Extensions software.