|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- delete a group definition from the system
/usr/sbin/groupdel [-S repository] group
The groupdel utility deletes a group definition from the system. It deletes the appropriate entry from the /etc/group file.
In addition to solaris.group.manage authorization, an administrator must have either solaris.group.assign or a matching authorization of the form solaris.group.assign/groupname to delete a group. The authorization solaris.group.assign/groupname is automatically assigned to the administrator who created the group.
groupdel supports the following option.
The valid repositories are files and ldap. The repository specifies which name service will be updated. When repository is not specified, groupdel consults nsswitch.conf(4).
An existing group name to be deleted.
The following exit values are returned:
Invalid command syntax. A usage message for the groupdel command is displayed.
group does not exist.
Cannot update the /etc/group file.
system file containing group definitions
See attributes(5) for descriptions of the following attributes:
The groupdel utility deletes a group definition that is in the group database in the repository.
groupdel fails if a group entry (a single line in /etc/group) exceeds 2047 characters.