|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- report free disk space on ufs file systems
df -F ufs [generic_options] [-o i] [directory | special]
df displays the amount of disk space occupied by ufs file systems, the amount of used and available space, and how much of the file system's total capacity has been used.The amount of space reported as used and available is less than the amount of space in the file system; this is because the system reserves a fraction of the space in the file system to allow its file system allocation routines to work well. The amount reserved is typically about 10%; this can be adjusted using tunefs(1M). When all the space on the file system except for this reserve is in use, only the superuser can allocate new files and data blocks to existing files. When the file system is overallocated in this way, df might report that the file system is more than 100% utilized.If neither directory nor special is specified, df displays information for all mounted ufs file systems.
The following options are supported:
Options supported by the generic df command. See df(1M) for a description of these options.
Specify ufs file system specific options. The available option is:
Report the number of used and free inodes. This option can not be used with generic_options.
list of file systems currently mounted
See attributes(5) for descriptions of the following attributes:
df calculates its results differently for mounted and unmounted file systems. For unmounted systems, the numbers reflect the 10% reservation. This reservation is not reflected in df output for mounted file systems. For this reason, the available space reported by the generic command can differ from the available space reported by this module.
df might report remaining capacity even though syslog warns filesystem full. This issue can occur because df only uses the available fragment count to calculate available space, but the file system requires contiguous sets of fragments for most allocations.
If you suspect that you have exhausted contiguous fragments on your file system, you can use the fstyp(1M) utility with the -v option. In the fstyp output, look at the nbfree (number of blocks free) and nffree (number of fragments free) fields. On unmounted filesystems, you can use fsck(1M) and observe the last line of output, which reports, among other items, the number of fragments and the degree of fragmentation. See fsck(1M).