|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- Kerberos database propagation program
/usr/lib/krb5/kprop [-d] [-f file] [-p port-number] [-r realm] [-s keytab] [host]
kprop is a command-line utility used for propagating a Kerberos database from a master KDC to a slave KDC. This command must be run on the master KDC. See the Solaris System Administration Guide, Vol. 6 on how to set up periodic propagation between the master KDC and slave KDCs.
To propagate a Kerberos database, the following conditions must be met:
The slave KDCs must have an /etc/krb5/kpropd.acl file that contains the principals for the master KDC and all the slave KDCs.
A keytab containing a host principal entry must exist on each slave KDC.
The database to be propagated must be dumped to a file using kdb5_util(1M).
The following options are supported:
Enable debug mode. Default is debug mode disabled.
File to be sent to the slave KDC. Default is the /var/krb5/slave_datatrans file.
Propagate port-number. Default is port 754.
Realm where propagation will occur. Default realm is the local realm.
Location of the keytab. Default location is /etc/krb5/krb5.keytab.
The following operands are supported:
Name of the slave KDC.
Example 1 Propagating the Kerberos Database
The following example propagates the Kerberos database from the /tmp/slave_data file to the slave KDC london. The machine london must have a host principal keytab entry and the kpropd.acl file must contain an entry for the all the KDCs.
# kprop -f /tmp/slave_data london
List of principals of all the KDCs; resides on each slave KDC.
Keytab for Kerberos clients.
Kerberos database propagated to the KDC slaves.
See attributes(5) for descriptions of the following attributes: