|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- display device attributes
devattr [-v] device [attribute]...
devattr displays the values for a device's attributes. The display can be presented in two formats. Used without the -v option, only the attribute values are shown. Used with the -v option, the attributes are shown in an attribute=value format. When no attributes are given on the command line, all attributes for the specified device are displayed in alphabetical order by attribute name. If attributes are given on the command line, only those attributes are shown, displayed in command line order.
The following options are supported:
Specifies verbose format. Attribute values are displayed in an attribute=value format.
The following operands are supported:
Defines which attribute, or attributes, should be shown. Default is to show all attributes for a device. See the putdev(1M) manual page for a complete listing and description of available attributes.
Defines the device whose attributes should be displayed. Can be the pathname of the device or the device alias.
The following exit values are returned:
Command syntax was incorrect, invalid option was used, or an internal error occurred.
Device table could not be opened for reading.
Requested device could not be found in the device table.
Requested attribute was not defined for the specified device.
See attributes(5) for descriptions of the following attributes: