|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- perform surface analysis
diskscan [-W] [-n] [-y] raw_device
diskscan is used by the system administrator to perform surface analysis on a portion of a hard disk. The disk portion may be a raw partition or slice; it is identified using its raw device name. By default, the specified portion of the disk is read (non-destructive) and errors reported on standard error. In addition, a progress report is printed on standard out. The list of bad blocks should be saved in a file and later fed into addbadsec(1M), which will remap them.
The following options are supported:
Causes diskscan to suppress linefeeds when printing progress information on standard out.
Causes diskscan to perform write and read surface analysis. This type of surface analysis is destructive and should be invoked with caution.
Causes diskscan to suppress the warning regarding destruction of existing data that is issued when -W is used.
The following operands are supported:
The address of the disk drive (see FILES).
The raw device should be /dev/rdsk/c?[t?]d?[ps]?. See disks(1M) for an explanation of SCSI and IDE device naming conventions.
See attributes(5) for descriptions of the following attributes:
The format(1M) utility is available to format, label, analyze, and repair SCSI disks. This utility is included with the diskscan, addbadsec(1M), fdisk(1M), and fmthard(1M) commands available for x86. To format an IDE disk, use the DOS format utility; however, to label, analyze, or repair IDE disks on x86 systems, use the Solaris format(1M) utility.