|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- remote execution server
in.rexecd is the server for the rexec(3SOCKET) routine. The server provides remote execution facilities with authentication based on user names and passwords. It is invoked automatically as needed by inetd(1M), and then executes the following protocol:
The server reads characters from the socket up to a null (\0) byte. The resultant string is interpreted as an ASCII number, base 10.
If the number received in step 1 is non-zero, it is interpreted as the port number of a secondary stream to be used for the stderr. A second connection is then created to the specified port on the client's machine.
A null terminated user name of at most 16 characters is retrieved on the initial socket.
A null terminated password of at most 16 characters is retrieved on the initial socket.
A null terminated command to be passed to a shell is retrieved on the initial socket. The length of the command is limited by the upper bound on the size of the system's argument list.
rexecd then validates the user as is done at login time and, if the authentication was successful, changes to the user's home directory, and establishes the user and group protections of the user. If any of these steps fail the connection is aborted and a diagnostic message is returned.
A null byte is returned on the connection associated with the stderr and the command line is passed to the normal login shell of the user. The shell inherits the network connections established by rexecd.
in.rexecd and rexecd are IPv6–enabled. See ip6(7P).
See attributes(5) for descriptions of the following attributes:
All diagnostic messages are returned on the connection associated with the stderr, after which any network connections are closed. An error is indicated by a leading byte with a value of 1 (0 is returned in step 7 above upon successful completion of all the steps prior to the command execution).
The name is longer than 16 characters.
The password is longer than 16 characters.
The command line passed exceeds the size of the argument list (as configured into the system).
No password file entry for the user name existed.
The wrong password was supplied.
The chdir command to the home directory failed.
A fork by the server failed.
The user's login shell could not be started.
The in.rexecd service is managed by the service management facility, smf(5), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). Responsibility for initiating and restarting this service is delegated to inetd(1M). Use inetadm(1M) to make configuration changes and to view configuration information for this service. The service's status can be queried using the svcs(1) command.