|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- reserve devices for exclusive use
devreserv [key [device-list]...]
devreserv reserves devices for exclusive use. When the device is no longer required, use devfree to release it.
devreserv reserves at most one device per device-list. Each list is searched in linear order until the first available device is found. If a device cannot be reserved from each list, the entire reservation fails.
When devreserv is invoked without arguments, it lists the devices that are currently reserved and shows to which key it was reserved. When devreserv is invoked with only the key argument, it lists the devices that are currently reserved to that key.
The following operands are supported:
Defines a list of devices that devreserv will search to find an available device. The list must be formatted as a single argument to the shell.
Designates a unique key on which the device will be reserved. The key must be a positive integer.
Example 1 Reserving a Floppy Disk and a Cartridge Tape
The following example reserves a floppy disk and a cartridge tape:
$ key=$$ $ echo "The current Process ID is equal to: $key" The Current Process ID is equal to: 10658 $ devreserv $key diskette1 ctape1
Example 2 Listing All Devices Currently Reserved
The following example lists all devices currently reserved:
$ devreserv disk1 2423 diskette1 10658 ctape1 10658
Example 3 Listing All Devices Currently Reserved to a Particular Key
The following example lists all devices currently reserved to a particular key:
$ devreserv $key diskette1 ctape1
The following exit values are returned:
Command syntax was incorrect, an invalid was option used, or an internal error occurred.
Device table or device reservation table could not be opened for reading.
Device reservation request could not be fulfilled.
See attributes(5) for descriptions of the following attributes:
The commands devreserv and devfree are used to manage the availability of devices on a system. Their use is on a participatory basis and they do not place any constraints on the actual access to the device. They serve as a centralized bookkeeping point for those who wish to use them. Devices which have been reserved cannot be used by processes which utilize the device reservation functions until the reservation has been canceled. However, processes that do not use device reservation may use a device that has been reserved since such a process would not have checked for its reservation status.